Pip won't let me install anything

I’m trying to install a package through Shell, but whenever I try, I get this error message:

an error occured during configuration: option use-feature: invalid choice: ‘content-addressable-pool’(choose from ‘fast-deps’,‘truststore’,‘no-binary-enable-wheel-cache’)

What should i do?

try this:

It says there is no such file or directory

Can you share the link to your repl?

Please ignore my bad code I suck

Try installing packages using the Packages tab in the editor (go to tools), or use poetry add instead of pip install in the shell.

I’ve already tried to use Packages, but it can’t
And the poetry add worked I think, but when I try to import it (nextcord), it says the module is missing.

I noticed you have something in your deps in your replit.nix file. Can you try removing that, reloading the shell, and trying my post again?

How would I do that? I’m new to this replit stuff, sorry.

Near your files, click the three dots and hit Show hidden files. Then, open replit.nix and replace all of the contents with the following:

{ pkgs }: {
  deps = [


It says it detected a change in environment, and is reloading shell

Oh, it worked! Thank you!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.