Pip install module permission denied

pip install module is giving me “permission denied”. Also when I try to run my app, it says that i the package openai is not install, but I can see it in the packages.

Please provide the exact error, and either a link to your repl (Preferred) or a code snippet.

Here’s the link to my repl, https://replit.com/@LarrySankey/websurfer-plugin.

Here’s the exact message:

~/websurfer-plugin$ pip install module bash: /home/runner/websurfer-plugin/venv/bin/pip: Permission denied

That is really weird. just tried adding via poetry on your repl and perms are denied to that too. Something really weird is going on here.

Try chmod a+x /home/runner/websurfer-plugin/venv/bin/pip


That’s not their only problem, at least 10 different packages are missing a METADATA file, poetry is also protected… I’m trying to figure out what all commands need to be run to fix that repl.


That worked. Pip install works now. I think maybe it’s because I copied an entire folder from my laptop. Maybe I got some weird permissions from doing that.

Yeah, that could also explain all the permission/METADATA errors too. I’ll get back to you in a second, beacuse your repl is still pretty broken.

I think maybe I should delete it and start from scratch. Only copy the program files instead of dumping the entire folder.

That might be a better idea.

1 Like

Thanks for your help. I’ll try that.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.