Pip install Error :(

Pip isnt working on replit

I tried using my old repls and creating a new one but it still stays the same.

I used the pip command to install a pypi package but it still doesn’t work :frowning:
also, when i created this repl i used the Python version

Try running poetry add YOUR_PACKAGE_NAME.

4 Likes

oh thanks!
but why cant i use the pip command anymore?
i read the updates and replit said that they updated their pips to a first class (which would mean that the pip command would be used directly and would be more faster)

1 Like

Not really sure. I thought so too, but poetry is just generally more reliable in Replit ig.

1 Like

OH ok.
Well, thanks :slight_smile:

1 Like

Replit’s python package environment is set up using poetry, and especially since mixing package managers can cause dependency conflicts and other problems, it is best practice to use poetry for managing your repl’s python packages.

5 Likes

That’s not strictly true anymore, see:
https://blog.replit.com/pip

Regardless, I do still recommend using poetry, it’s easier to use IMO

3 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.