Package operation failed

Question: pip replit package operation failed

Repl link:

Basically, I tried installing the module getkey through python code, and then through the replit packages manager. Both times, I received an error:
Replit: Package operation failed.

Anyone know if this is just a package error or a replit error?


Hi @JBloves27 , welcome to the forums!
Can you try entering poetry add getkey into the Shell?

1 Like

Hey @NateDhaliwal, thanks.
Tried that, got the same error without the replit error text. Seems like the package code is returning an error no matter how I try to download it. Any other suggestions?

Hi @JBloves27 ! Could you send the link to your repl?

Yeah, gotcha -
(Note that it’s just an empty repl with only an idea to get me started as of right now)

Hey @NateDhaliwal, seems like the final error after running pip install getkey was the following:

It seems that nothing I throw at it works… not even the package installer.

That would imply there’s a version mismatch somewhere. I’ll look, but in the meantime you could look at using fkeycapture (a package I made).

Got it! Run this in the Shell tab:

pip install getkey --use-pep517

Hey @Firepup650,
Thanks! It worked! Would you mind explaining why adding the additional arguments to the installation command helped?

1 Like

I’m not sure, but I read the log, and I saw that argument mentioned at least twice.

I suspect something was out of date, or had a bad default set.

I also noticed once I ran that in verbose mode (with that arg) it downloaded a lot more packages, so maybe some required package used for building was missing.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.