Package of previous version

I wanna install the replit package. And when i search for the replit package it shows me the 3.2.4 but it gives me error as the version of flask which is need to use is not supported by 3.2.4 so I wanted to install the previous version 3.2.3 of replit. Doing it with pip install replit==3.2.3 is an option but a package would be better as I dont have to go to shell everytime I open it. If you have some reference pls share whould be much appreciated.
Screenshot 2022-08-12 195325

Hi @p_m_9_8_6 thank you for your message.

I’ve just tried to replicate this by creating a new Python Repl and searching for “replit” in the packages tab.

It appears to be already installed for me. Can you describe the steps you followed to get your screenshot please?

image

@IanAtReplit, @p_m_9_8_6 wanted to change the version of Replit installed due to needing to use a different version of a dependency. I don’t think they were having trouble installing the package.

@p_m_9_8_6, you can set exact versions of dependencies in pyproject.toml for replit you can do the following:

[tool.poetry.dependencies]
...
replit = "3.2.3"
Flask = "2.2.0"

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.