Output window: "There was an error connecting to the server"

Problem description

Output: “There was an error connecting to the server”
The output window will not connect correctly upon opening a pygame file, the program has not even been ran yet. Running the program then clicking “try again” will eventually run the output for some users but not all. Alternatively the page can be freshed while the program is still running and as the page loads the output window will show the same error then a few seconds later loads. These steps do not work for everyone, some the problem persists indefinitely. This has been tested on devices that previously had never visited replit to have any stored cache/cookies and the issue is present immediately. At the time of this post it cannot connect to the server at all and there is no URL displayed per the diagnosis message to check. In chrome dev tools/sources there are websocket connection errors to repl.co/ and janeway.replit.dev/. We currently have *.replit.dev, *.replit.com, *.cdn.replit.com, and *.repl.co whitelisted in our firewall.

Expected behavior

Output window should be a black screen upon successful connection to the server then display the pygame output once the code is ran.

Actual behavior

Output window displays error connecting to the server when even opening the repl. Clicking “Try Again” or refreshing the page results in the same behavior

Steps to reproduce

Open pygame file: https://replit.com/@ChadKing1/Pong-1

Browser

Chrome 118

OS

Windows 10

Device if mobile

N/A

Plan

Free tier

image
image

I just tested forking the same pygame file I included in this ticket to: https://replit.com/@mcsstudent01/Pong-Output-Testing
And if I run the program then click try again the output window is now displayed.