Output window continuously loading

Problem description:
Run window continuously loading. The loading circle never goes away in the run window. This seems to be a new problem since I’ve been using this website for a few years on and off and am only now seeing this behavior in the past few weeks since I started reusing the website. This issue happens with old and new programs. This is a personal device at home. The same issue is happening with my kids’ PCs as well. I see similar issues reported by others, but I see no solution in any of those threads. I’ve tried the cover page, tried putting the code into a new repl, tried clearing my browser cache, etc. Here’s some of the other threads I see with the same problem:

Expected behavior:
Run window to show output

Actual behavior:
Run window constantly loading.

Steps to reproduce:

Bug appears at this link:

Windows 10, Chrome browser, HP desktop

1 Like

This seems to be a common issue recently, and it may need to get moved over to the Replit team for investigation.

1 Like

Thanks Bob. How do we go about doing that?

Not really sure, but there’s a lot of staff on the site, I could probably message one later and hopefully they could pass it to the team.

I tried running on Microsoft Edge, but we get the same problem, so it seems like it may not be a browser issue.

Can you try it on a different WiFi network and see if the issue persists? If it does, could you please check what your server location is set to under your Account tab?

Server location is North America. I’ll let you know the results when we are able to try it on a different wifi network.

1 Like

I am having the same problem. Tried firefox, chrome, and edge. Two different computers.

Did you try on different WiFi networks?

They already have tried that.

1 Like

I’m having the same problem on two different Repls.


1 Like

I am having the same issue specifically with running Python with Turtle. It was working fine a couple of weeks ago and then one day when I tried it, it would not load. It has been happening for several days. I have tried multiple browsers, different computers, Windows 10 and Windows 11. It does not work on any of them.

Hey @pgupta73!

This might be an issue with your network. Can you please check if https://replco.shaneatreplit.repl.co/ (a test site) loads on your end? If not, your network or a browser extension might be blocking repl.co, which is essential for us to serve webpages and graphics output to the workspace of Repls.

1 Like

I tried that website and it seems to work. I get:

If you can see this, repl.co works!

Thanks! Could you send me the link to the Repl that you’re seeing the issue on so I can take a look?

Also, are you able to view this page: https://81d2fa53-da80-4d06-b96b-054d304e2974.id.repl.co? It’s the same as my replco example, but uses a different URL.

Hi Shane. Thanks for looking into this issue. I’m traveling at the moment and hence can’t reproduce the environment in which we were having problems. Now that I’m at a place with a different wifi network, things are working on at least some of the devices which were failing in the original wifi network. I’m not able to get anything to “fail”. FWIW, the link in your message works as before, though I am on a different machine on a different network, so that data point may not be too useful. Bottom line is that it appears that perhaps this is some kind of wifi network issue. I can send you the requested info once I return to the original wifi network. In the meanwhile, if there’s any other info I can provide, please let me know.

1 Like

Well, everything is magically working now, so I assume the folks at repl fixed the issue. It’s the first time I tried it in a couple of weeks, so I’m not sure when it got fixed. Thanks for your assistance, Shane.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.