Output not working: "There was an error connecting to the server"

My Output no longer works on any replit, in any language. Instead, I get an error message: “There was an error connecting to the server”. Additionally, I get this message:
"Open this link and check if you can visit this URL from your browser: 10622591-6a32-44be-aa89-1421705f33ea.id.repl.co.

If you see a browser error, it’s possible that your ISP have security settings blocking the URL. Please contact your ISP and ask them to unblock the URL above. Here are the support links for common ISPs:

  • [Xfinity]
  • [Spectrum]

If I try to go the the link, it takes me to a replit screen that says:
“Not found error: This is not the page you’re looking for. If you think this is a mistake, check the status page for active incidents, contact support or ask the community.”

Output used to work, and I’ve only had this issue recently

This happens on any file with an output window.

Because I am a “new poster,” apparently I am not allowed to have two links in my post, so I can’t give a link to my program

Browser/OS/Device: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/120.0.0.0 Safari/537.36

Replit Profile: https://replit.com/@JeffreyPogue

Thank you for your help!!

Hello,
if the issue started quite recently, a day or less, then it is most likely linked to an active replit problem:

Also, the link on the Diagnosis is outdated so don’t worry about that.

I don’t believe this is the issue, because it has now been a few days and the issue persists. Additionally, it continues to not work even in the desktop app. It makes replit (or at least the best features of it) almost completely unusable. What should I do?

i am facing this issue from last 1 week.

I’m facing exaclty the same since 1 week. I have asked support and they told me to look in the Forum for help. Not sure it will but definetely keep watching this problem.

This issue is still going on! Hi Replit staff! Can you give any update? Is this something you guys are aware of? You have been really helpful for me in the past and I would like to keep my faith high!

Hi there @JeffreyPogue. The issues should be resolved.

For your “Hello World” Repl, if you press the green run button, you will notice the console has syntax errors. You will need to correct the syntax errors so your output can correctly refresh instead of caching the old error.

If unresolved after fixing the syntax errors, I recommend clearing the browser cache and flushing the DNS. Thanks so much.

1 Like

Is this issue still ongoing for others or is it just me? I have tried clearing my browser cache and flushing DNS.

In my case the console runs fine, it will say if there is any syntax and runs prints but the output screen is just stuck on “there was an error connection to the server”. I have also tried on multiple devices and get the same issue on them all.

Please help I need this code finished in 2 weeks and it doesn’t help if I can’t test it!

@JeevanBasra Have you addressed the syntax errors? If so, may I request you to make a new post with the details of the error/URLs you are seeing? Any screenshots/recordings and a link to the public Repl will be helpful.

Feel free to mention me on the new post as well.

@SuzyAtReplit I have done everything as well, and it still doesn’t work. The error occurs even before I have written any code, as there simply is no Output tab on the right. Therefore, if in python, for example, I can’t use input(). This also is true for me across multiple devices and accounts. If I create a Go file, I get an Output tab, but it still says “There was an error connecting to the server.” Additionally, when I open Output manually, it still says the same error. Is it possible Replit (the company) completely removed the “Output” functionality? If so, what feature replaced it.

@JeevanBasra Do you have a link to the new post you created with the requested details? We can help you there.

@JeffreyPogue We see the example “Hello World” Repl in your account. It’s strange that you got a VNC output window at all since this Repl has nothing to do with graphics. Note that the output window is a graphical output while the console and webview are different types of tools.

We’ll look into the example but hope the information helps.

5 Likes

Our school district is experiencing this as well. I’ve confirmed the issue occurs both on/off our network.

The output window will not connect correctly upon opening a file, the program has not even been ran yet. Running the program then clicking “try again” will eventually run the output for some users but not all. Alternatively the page can be freshed while the program is still running and as the page loads the output window will show the same error then a few seconds later loads. These steps do not work for everyone, some the problem persists indefinitely. This has been tested on devices that previously had never visited replit to have any stored cache/cookies and the issue is present immediately.

I’ve looked in the dev tools and see multiple websocket connection errors to repl.co, and replit.dev which have been whitelisted in our firewall and webfilter. Regardless of that, it happens when off of our network and no webfilter is being applied at all.

Browser: Chrome v1180.5993.118, ChromeOS v120.0.6099.272
Device: Windows10 Lenovo ThinkPad L13 Yoga Gen 2, Dell Chromebook 3100
Repl: https://replit.com/@ChadKing1/Pong-1

@colesh1 Thanks for the details. I forked the Repl example, but didn’t see any issues.

The issues you mention are not the same bug as the one reported in this thread. The Repl reported here should not have an output to begin with so that’s the bug we’re looking at. Your Repls should have an output so this is different. I’ll go ahead and resolve this thread so we don’t have further confusion.

However, there are a lot of threads in Ask (particularly with schools) reporting issues similar to yours so can review those or find more as well. I’ll link a few, but you’re also welcome to create your own post.

There isn’t a one-size-fits-all answer. The IT team at your school district may be able to assist further by analyzing packet traces.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.