Outage: readonly filesystems, connection failures, and other errors

getting still the saem error: as 5 days ago. how long this will take??? i m writing from europe/germany

with get_handle(
  File "/home/runner/81-copy-8-clean/venv/lib/python3.10/site-packages/pandas/io/common.py", line 859, in get_handle
    handle = open(
OSError: [Errno 30] Read-only file system: 'po.csv'

My repl still doesn’t work. I guess I’m one of those unlucky 2% people, i mailed them several times, they aren’t doing anything , at least if they can’t recover it, please provide me the source for ir, so i can get the service running

Repl link : https://replit.com/@samirawm7/Nyx-Ai

Issue : All files are missing/deleted except main.py

Help, please!

Repl is private!

1 Like

Problem description:
I cant see my main.py file because repl is just loading all the time. I can open some files but not all. tried both, app and website.

Expected behavior:
I should see the file

Actual behavior:

Steps to reproduce:
open repl

Bug appears at this link:

Browser: Chromium
Device (Android, iOS, NA leave blank): Ubuntu 22.04
Desktop app version (Avatar menu->“Version”) or NA: 1.0.1
Plan (Free, Hacker, Pro Plan): free

1 Like

Dont worry. youre not the only one because I have it too. im from europe/finland

1 Like

My repl isn’t loading ever since the issue started two days ago. First it was “we found an issue with your repl” then that message went away and not the code just doesn’t load.

I have tried all the usual replies, exit, log out, refresh, new browser et. al


Welcome to Ask!

1 Like

ok i understand now

and before continuing to read, u should remember that the staus in staus.replit.com tells that the issue is resolved

but why am i still having issues with my repl
and i am 100% sure that there is no problem in my code
and this is a question on ask.replit.com that contains the issue and the code and in addition to that the console log Outage: readonly filesystems, connection failures, and other errors - #170 by ahmadshaheen1

1 Like

@ahmadshaheen1 status.replit.com also says that only 98% of Repls are fixed.


Bug description:
Console says “nix error: building nix env: problem reading ‘.replit’ file: failed to open .replit: open .replit: input/output error” and fails to load my files

Expected vs Current Behavior:

Steps to reproduce:

Bug appears at this link: https://replit.com/@laszlopota1/react-test

Screenshot(s)/Screen Recording:

Browser/OS/Device: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

Replit Profile: https://replit.com/@laszlopota1

1 Like

I’ve been sending messages asking for a response but I’m not getting any response, I just want them to bring my project back up to date. 29/09/2023, 12:00 Pm (UTC)

That’s all I ask for but they don’t give me an answer…

1 Like

If you actually read the message, it says that the issue is considered resolved, but around 2% of affected Repls have yet to be restored. It also urges you to make contact via the email status@replit.com.


thank you so much for your help
you are very helpful


hello i am still receiving that error.

  File "/home/runner/8-clean-life-light/a4_positions.py", line 26, in get_positions_df
    positions_df.to_csv("positions.csv", index=False)
  File "/home/runner/8-clean-life-light/venv/lib/python3.10/site-packages/pandas/core/generic.py", line 3772, in to_csv
    return DataFrameRenderer(formatter).to_csv(
  File "/home/runner/8-clean-life-light/venv/lib/python3.10/site-packages/pandas/io/formats/format.py", line 1186, in to_csv
  File "/home/runner/8-clean-life-light/venv/lib/python3.10/site-packages/pandas/io/formats/csvs.py", line 240, in save
    with get_handle(
  File "/home/runner/8-clean-life-light/venv/lib/python3.10/site-packages/pandas/io/common.py", line 859, in get_handle
    handle = open(
OSError: [Errno 30] Read-only file system: 'positions.csv'

Is there something i can do? like copy and paste everything. i think i cant import dataframes from other modules as this is what i am reading . should i do an update or am i now the only one where the error still appears?

If you’re still having read-only issues, you should email support at support@replit.com.


yes thats what i did already 3 times or so after OSError: [Errno 30] Read-only file system: . I am writing every second day an email but never receive an answer so i dont know what to do. Its really disappointing. I pay the pro and i cant do anything since 6-7 days. my algo stopped and i am afraid that this will happen in the future again.

added: I tried to update some libraries but then i rereive aditionally
ERROR: Could not install packages due to an OSError: [Errno 5] Input/output error

…dont know what if that is correlated

The OSError: [Errno 5] Input/output error message indicates that your program encountered an Input/Output (I/O) error while attempting to read from or write to a file, device, or network. I/O errors occur when a program tries to perform an input or output operation, but the operating system encounters a problem while accessing the data.

Here are some common reasons why you might encounter this error:

  1. Permissions Issue: The program might not have the necessary permissions to access the file or device. Ensure that the program has read and write permissions for the file or directory it’s trying to access.
  2. File Not Found: The file or directory you’re trying to access does not exist. Double-check the file path and make sure the file or directory you’re trying to access actually exists.
  3. Disk or File System Issues: If the error occurs when accessing a file on a local disk, it could indicate issues with the disk, such as bad sectors or file system corruption. Running a disk check utility (like chkdsk on Windows or fsck on Unix-based systems) might help identify and fix disk-related problems.
  4. Network Issues: If the error happens during network operations, it could be due to network problems. Check your network connection, firewall settings, and ensure that the remote server you’re trying to access is reachable and responsive.
  5. Hardware Failures: In some cases, the error might be caused by hardware failures, such as a failing hard drive or faulty storage device.

Hello there,

Please use our forum at https://ask.replit.com for technical support:

Bug reports | Replit Help | Code Help | Feature Requests

The Ask Forum is our official channel to receive technical support from the Replit team and our community.

You can also ask Ghostwriter your question in the workspace; it knows a lot about Replit, and has even read our Docs.

Have a great day!


Sometimes users get stuck in a support loop lol.

1 Like

Problem description: You announced that all the fixes are completed, but my repl is still not working. I request urgent support regarding this issue. The following error still appears.

I’ve been waiting for a solution for 1 week. Can someone help urgently? The main file waits without the codes appearing as follows. When I press the Run button, I get the following error. Urgent support please.

Bug appears at this link: [StimulatingUtilizedComment - Replit]https://replit.com/@Jaymz86/StimulatingUtilizedComment

Browser: EDGE
Device (Android, iOS, NA leave blank):
Desktop app version (Avatar menu->“Version”) or NA:
Plan (Free, Hacker, Pro Plan): PRO

Hello! Chiming in here because I’m not sure what else to do. Here is my linked private project:


When I sat down to work on this project last Friday, parts of it had suddenly reverted to a previous draft, including my file architecture:
Files missing or incorrect that I can recall:

  • index.js is not fully up to date
  • slackHelpers.js
  • slack_actions folder and all of its contents
  • slack_events folder and all of its contents
  • several files in the modals folder

I’m not sure where to begin in fixing it, as some scripts reference filepaths that no longer exist or reference other scripts that are now out of date, while some appear to be fine. I’ve had a bug report opened:

I’ve gotten no response to the bug report. I’ve also emailed support@replit.com and have been messaging with @LenaAtReplit. My last message with support was them saying that the project looks up to date, but it absolutely is not. I’m sorry to be hounding folks on all channels, but it has been almost a full week of lost work time waiting for a fix. With no clear guidance, I’m not sure whether I should just start over or continue to wait. Can I please get some clear timeline on a potential fix?

I’m relatively new to replit, so this has been a huge part of my experience: can anyone advise me on whether this is typical for replit? The severity of impact on the project leads me to believe I should not be prototyping here.

i still haven’t gotten anything replying to my issue and my replit still isn’t working. i cant even access the python with my source code. ):