"Open in a new tab button" not working

Problem description:
The “open in a new tab” button is not working.

Expected behavior:
Should open website in a new tab.

Actual behavior:
Opens a new tab that displays “Run this Repl to see the results here.” When you go back to the repl and click run, nothing changes in the tab. Tried to use incognito and clear cache; same issue.

Steps to reproduce:
Click the “open in a new tab” button.

Bug appears at this link:


Hey, @mathguy319 welcome to the forums!

Can you please provide a link to the repl? This way it is easier for staff and members of the community to help you!

Also see this guide on how to share your code:

1 Like

Here is one of the repls but it’s happening to all of them.

That repl is private, could you either make it not private, or link to a public one?

I do not have any public repls.

Could you make a repl that contains the bare minimum required to reproduce the error? (And make it public)

Alternatively, could you link the site that one of the problematic repls hosts?

Thank you for your assistance. The public repl I just created does not have the issue. I noticed that the url in the Webview screen for the repls for my class has an extra dash between the title and the team name. Could this be related to one of the status issues?

Possibly, try seeing if you can remove that dash, as it might be confusing the system.

Tried that already. No success

What’s the repl name as shown in the editor?

Web Project Pgs 1-3-mathguy319-

Try changing it to Web Project Pgs 1-3-mathguy319-test. If that works, you can probably then change it to Web Project Pgs 1-3-mathguy319.

Thank you but that’s not working. It’s giving me the same page

Current repl name + url?