Not recompiling code changes

Students project isn’t recompiling. I downloaded code and opened in JCreator and it ran the modified code. How can I force repl to recompile to pick up changes? I have tried running on two different computers at school and one at home

1 Like

Can you please clarify what language you are using? If it is not re-compiling, try:

  1. restarting the repl by running kill 1
  2. For your language, change the command to hard-recompile without caching every time

Hey @PESHHorton!

Can you please send me the link to one of the projects that aren’t recompiling?

Thank you for replying! Unfortunately, your email went to my junk folder. I really hate when they decide they know what I want to see and what I probably dont.

The one that doesn’t recompile is:
There are several print statements that should be showing up ( was trying to debug why things weren’t happening). First one is at the very start of main: System.out.println(“in main”); – so just letting the menu pop up would get that message.

I created another project in her class, she copied her code over, and it worked in the new version:

I had also downloaded it and ran it on JCreator IDE and it worked fine. So not sure why the one version wouldn’t recompile. I tried modifying the lower object classes, creating a new class, etc - but nothing seemed to work. I gave up and created the new spot for her to work (which did work / second link)

Although I got around it this time, I’d really like to know what to do should I have the problem occur again in the future.

Ann Horton
Plano East Senior High School


I have great news: We found the issue!

It looks like the compile command (a command we run before the main run command) was misspelled and wasn’t running properly in the first Repl you shared, which is why the code wasn’t recompiling.

We think everything is good now. Can you check again to see if the issue is still there?

1 Like