Not able to log in to desktop app via Gmail

Yes, it redirects me back to the browser

Corey McCoy

Still doesn’t work for me and I don’t get the answer. This is clearly some sort of bug

at least on windows, there is only 1 “click here” text, and it is on the app which redirects to “https://replit.com/login?desktopAppAuthFlow=1” again and again. There is no other signature link on this page, nor anything else to redirect to the app. It also does not have anything after logging in.

and again, it is Edge browser.

PS: you moved my post here but the title of this discussion has “Mac” in it, maybe move the problem to a new one?

1 Like

i’m having this exact same issue

Hi everyone!

So sorry that you all are experiencing issues logging in. I’m the lead engineer on the desktop app so I’m happy to chime in here to help get this resolved. The browser-based login flow has been working well for most people but unfortunately seems to have some issues on older browsers/OS’s or for people with certain preferences enabled in their browser.

We are still actively investigating what causes this issue but the best thing I can suggest is to ensure that you enable the Replit app to open in response to replit:// links.

You should have seen a prompt for this in your browser (FF, Chrome, Safari, Edge, etc) the first time that you tried to login after installing the app (e.g. when you see the “success” page in your browser). If you did see this prompt and you opted to prevent those types of links from opening in the desktop app, then your browser will never be able to redirect back to the app in order to complete the authentication process. If you did not see this prompt, then it’s possible that you have a setting enabled in your browser that prevents these types of dialogs from appearing and always default to the browser or another application for external links with custom protocols (e.g. replit://*).

Therefore, you will need to go into your browser’s settings and find a way to re-enable this prompt and ensure that all replit:// links open in the app. Re-installing the app or switching your external browser could help mitigate this issue. From there, you can simply open https://replit.com/login?desktopAppAuthFlow=1 in the browser (make sure you’re logged in already) and that will redirect you back to the app to complete the process.

I will also look into adding support for other ways to login since so many people are having issues but this will be your best bet for now. In the meantime, let’s re-open this issue @not-ethan since the accepted solution still does not work for everyone.

Thanks,
Sergei

6 Likes

:wave: Welcome to the community, @UmarQureshi6!
On this page, it says Your Browser should open automatically, if it doesn't click here. Where it says click here in the blue coloring, please press that.

2 Likes

For me, once I log in (On Chrome), it directs me to the Replit home page. I have tried it with a different browser (Firefox), and I have the same issue.

I verified that the issue is not browser related. I tested with the latest version of Safari and Chrome. I also quit the Replit app, and made some test requests to replit://* to ensure that my browser is able to handle the replit protocol correctly. It does.

I went through the auth flow with my network tab open and didn’t see any requests made to replit://*. This could be a red herring, but just throwing that out there, I would expect a redirect to show up. Also the ~ request is immediately after the auth request. I don’t think anything else is happening in between. Seems like an issue with the /auth endpoint and not user or os error. Actually after I comment I’ll test this further by logging in via email/password instead of oauth. Maybe the callbacks are a lil goofy.

Could you just give us the redirect location so that we can enter it in the browser ourselves? In theory I should be able to just visit the replit:// link that the auth flow is supposed to redirect to. The /auth request has the connect.sid right there which is what I’m assuming is what gets passed back to the electron app for authentication?

I just want to use the desktop app!!! Thanks for building it.

2 Likes

same problem i m on window

I just installed the replit app but when I press on the login link which redirects me to the login page, I login, but when I return to the app it still has not noticed and I still see “Your browser should open automatically. If it doesn’t, click [here]” text and it stays there no matter how many times I log in. I tried google login and normal email and password log in, SAME PROBLEM!

It is supposed to log me in the app

But it doesn’t and keeps showing the login link as if I still haven’t logged in.

Download and install the app and try to log in. This should reproduce the bug.

Bug appears when I press the log in link showed in the app and log in on the website.

Browser: Edge
OS: Windows 10
Device (Android, iOS, NA leave blank): PC
Desktop app version (Avatar menu->“Version”) or NA: app version 1.0.1
Plan (Free, Hacker, Pro Plan): FREE

Hi @morx710 , welcome to the forums!
This is a known problem and the team is working to fix it.

1 Like

Problem description:
Replit desktop app opens in a browser while the actual app remains suspended.

Expected behavior:
The replit app should offer the interface in the app without a browser.

Actual behavior:
Clicking on the new app opens the wrong browser (it opens firefox instead of chrome), where upon a successful login, opens entirely inside the browser, making the app redundant, since this is no different from surfing to your site and doing the same thing with nothing installed.

Steps to reproduce:
Double-click on Replit app on the desktop. It brings up a window offering a login. Login opens the default browser to log on. Log on. Browser now is in control of the login, with the app becoming essentially a zombie process.

Bug appears at this link:
No link required

Browser:
Firefox 117.0.1
OS:
Windows 10
Device (Android, iOS, NA leave blank):
Laptop
Desktop app version (Avatar menu->“Version”) or NA:
Hard to say, since the desktop app goes blank and has no interface. I recall it was 1.0.1 or something.
Plan (Free, Hacker, Pro Plan):
Teams for Edu

Hi folks, we’ve fixed what we think is root cause for this issue. I am able to log in to the desktop app with Google. Please reply if you are still having issues with desktop login. Thanks for your patience!

7 Likes

I tried that but it didn’t work.

It’s fine now it seems that the bug has been fixed. Thank you for your help @RedCoder

1 Like

Hey @UmarQureshi6!

Please mark this post as the solution if it solved your problem so people with the same issue can easily find the solution.

cc: @QwertyQwerty88 @dragonhunter1 @MattDESTROYER @Firepup650

OK thank you very much for your help :+1:t3:

It is interesting that there are two posts marked as an answer. this needs an extra attention from forum coding team.

Anyways, I think the problem was with the login page with the “?desktopAppAuthFlow=1” parameter as it was not log us in automatically, and if we login the it was forgetting what was that parameter.

It now performs the login and redirects to the repls page, along with the request to open a link in an associated application, in this case the replit desktop app.

I believe the problem should now be solved regardless of the system as long as the browser allows redirections and the app is correctly set to open a “replit://” url.

That’s completely normal and happens if you merge a post that was marked as a solution into a topic that already had a solution (@Firepup650 actually created a topic with ~5 solutions on a community-run forum once iirc). Also, Replit did not create Discourse, although you could create a topic on Discourse Meta about topics being able to have multiple solutions if you want to.

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.