No available video device, repl process died unexpectedly when using cmu_graphics

Hello all! A number of my students trying to use CMU CS Academy’s graphics package using the cmu_graphics Repl, but on some programs that were previously able to run and display the graphics, the Output window is now showing us a spinning wheel of death, and when it tries to display the output, it seems to hang for a few seconds before I get the following in the console:
error: no available video device repl process died unexpectedly

I’ve tried rebooting the Repl using busybox reboot but rebooting the Repl doesn’t seem to change anything.

I’ve also tried forking the project, creating a new Python-CMUGraphics Repl and copy/pasting the code into it, and creating a brand new blank Python-CMUGraphics Repl and running that. Sometimes the Output window never even shows up and does not even appear in the tools menu, but it feels oddly inconsistent. I’ve checked in every instance to make sure that from import cmu_graphics * is at the beginning and code is at the end of the program.

Are there other troubleshooting steps that I can take?

1 Like

it seems there is an issue right now about video devices

This has been reported all over Replit ask, so it may soon be fixed!

1 Like