Nix error when i try to run simple code in

can you share the link ot the repl

1 Like

nvm im blind sorry i didnt see that you shared it

1 Like

nvm it dont work
the link shows nothing

1 Like

i tried doing this and i don’t get the nix error anymore it seems but i’m still not able to run my code ?

1 Like

Welcome to Ask @TeresaCS!

Since your Repl is private, could you share the contents of your replit.nix file?

i changed it to this:

{ pkgs }: {
	deps = [

according to what i saw here.

Can you show the last few lines of that nix error message? If it’s looping in Console, then try checking Shell.

after replacing the contents of the replay.nix with what i saw in the post i linked i no longer get the nix error, but i’m still having issues.

when i try to do a simple comparison i get:

am i being dumb? i don’t get what’s going on

No, you’re not. It’s just that prybar (The thing that runs the interactive Console) is no longer a part of the default tempate. You could either make a new Repl with prybar, or change your Repl’s .replit file to match a Repl with prybar.

i tried making a new Repl, using the template Python (with prybar), but i’m still having the same issue:

this is what’s in the .replit file:

here’s the link:

You have to run the repl before you’ll be able to use the console like before.

1 Like

ah i see! thanks sm! it works now! :')

1 Like

sorry to bother u again!
it seemed to be working on that public repl i linked. i then went into my private one, made the same changes, but over there i didn’t get the same result i got at first with the public repl. i clicked Run and it just runs indefinitely, with no end in sight (unless i click Stop). went into my public one again, and now i had that problem over there as well:

any idea what’s happening / what i’m doing wrong? i’m really at a loss.
i should probably mention i’m a newbie :confused:

Try running kill 1 in that Repl’s Shell tab.

still running indefinitely when i click Run after:

repl link:

If you see that orange prompt, it means your program has ended.
It does still stay “Stop” but that’s because it’s not really running prybar as an interpreter (which is why you have to “Run” before it starts). This is to work around friction with interpreters experienced on modern, multi-language repls, such as this

1 Like

ah i see!

however, once i click Stop, whatever i input into the Console doesn’t work anymore (see the 2nd “a < b” that returns “bash: 2: No such file or directory”, that one was after clicking stop; the previous one was when it was apparently still running ). is that normal?

i’ve been using Replit for a couple of weeks now and never had any issues such as this

they might push a fix for this at some point, but for now you have to work with interpreter and its little quirks:


okay, thank you for the help!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.