Need to add libmagic1

Need to add libmagic to use langchain package methods

Repl link:

code snippet

Hi @royaldevops , welcome to the forums!
If you need to install the libmagic module, enter pip install libmagic into the Shell. If that doesn’t work, enter poetry add libmagic into the Shell.

1 Like

@NateDhaliwal We are using python-magic its relaid on libmagic1

I need to run below commands in shell:

  1. pip install python-magic
  2. sudo apt-get install libmagic1

So you’ve tried both?

@NateDhaliwal sudo apt-get install libmagic1 doesnt worked
given below output
sudo: The “no new privileges” flag is set, which prevents sudo from running as root.
sudo: If sudo is running in a container, you may need to adjust the container configuration to disable the flag.

Replit does deny a lot of permissions, so sudo doesn’t work.


You can disable that though? I can’t really remember it…

I don’t believe so, Replit’s perms denial is a bit overboard. I had issues when installing a PostgreSQL package earlier today.


@NateDhaliwal at least can we run the project considering macos?