My website is not loading on replit

Problem description:
When i start up my repl, the website window and dns just hangs and doesnt load for me.

Expected behavior:
The Website loads like every other REPL.

Actual behavior:
The website hangs and doesnt load.

Steps to reproduce:
No clue, just randomly started.

Bug appears at this link:

Chrome / Windows / Laptop

Have you tried reloading the page/ waiting a day or so. I’ve had this glitch before, it’s better just to go to the webpage on a new tab.

try after entering kill 1 in Shell. If not, try on a fork of your repl

1 Like

Can you send a link to the actual repl, it could be because you’ve tried to load/import to much information

The Repl is here. You can also find any Repl’s page if you have the URL by adding __repl to the end of it. (EX:


ive dont that the new tab is not loading and the window in the repl workspace is not loading either

ive tryed both of these still getting the loading issue

would it help if someone forked the repl and tryed to seek out why its doing this?

ok its working now so its been fixed.

1 Like

Hey @maragi. It’s great to hear that you’ve solved your problem, but please provide an explanation to how you did, so that other people who have the same problem know the solution.


so it was an issue in the code that was somehow making it hang in your fork you should have maracms-includes/footer/data.txt its in there

its the file get contents were im attempting to get a file relative to the root domain, we have an issue with that tho

figured that out i had to use $_SERVER[‘DOCUMENT_ROOT’] . ‘/path’ to refer from the root of the repl

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.