My Replit suddenly stopped to work, because oh the missing file "GLIBC_2.38"

Problem description

My Replit was working perfectly until yesterday 02/06/2024.
Now, I can’t run, deploy, or install a package.
Replit got frozen…

Expected behavior

Would be expected that the Replit will work as always…
That is, with all functionalities working normally.

Actual behavior

The script only runs on debug mode !
When I try to deploy the program, the following error on "Promote " step appears:

Installing packages
/nix/store/8w6mm5q1n7i7cs1933im5vkbgvjlglfn-python3-3.10.13/bin/python3: /nix/store/dg8mpqqykmw9c7l0bgzzb5znkymlbfjw-glibc-2.37-8/lib/libm.so.6: version `GLIBC_2.38' not found (required by /nix/store/8w6mm5q1n7i7cs1933im5vkbgvjlglfn-python3-3.10.13/lib/libpython3.10.so.1.0)
exec [python3 main.py] error=exit status 1

When I run  the script,  pressing the "Run" button, the following error appears :

/nix/store/8w6mm5q1n7i7cs1933im5vkbgvjlglfn-python3-3.10.13/bin/python3: /nix/store/dg8mpqqykmw9c7l0bgzzb5znkymlbfjw-glibc-2.37-8/lib/libm.so.6: version `GLIBC_2.38' not found (required by /nix/store/8w6mm5q1n7i7cs1933im5vkbgvjlglfn-python3-3.10.13/lib/libpython3.10.so.1.0)
/nix/store/8w6mm5q1n7i7cs1933im5vkbgvjlglfn-python3-3.10.13/bin/python3: /nix/store/dg8mpqqykmw9c7l0bgzzb5znkymlbfjw-glibc-2.37-8/lib/libc.so.6: version `GLIBC_2.38' not found (required by /nix/store/8w6mm5q1n7i7cs1933im5vkbgvjlglfn-python3-3.10.13/lib/libpython3.10.so.1.0)
/nix/store/8w6mm5q1n7i7cs1933im5vkbgvjlglfn-python3-3.10.13/bin/python3: /nix/store/dg8mpqqykmw9c7l0bgzzb5znkymlbfjw-glibc-2.37-8/lib/libc.so.6: version `GLIBC_2.38' not found (required by /nix/store/3wvj2nbynari4iirc4yx3mhf26hbjr9s-libxcrypt-4.4.36/lib/libcrypt.so.2)

Steps to reproduce

Try to run and deploy a Python Script

Browser

Chrome

OS

Windows 10

Device if mobile

Android

Plan

Core Membership

Hi @fotografiadmd. We pushed an upgrade that seems to be causing this issue. We’re going to revert the changes shortly.

1 Like

Hi @fotografiadmd !
In the meantime, try doing what was mentioned here:

Hi @SuzyAtReplit , the stable-23_11 fix worked for us yesterday but today we’re now getting this error when trying to do anything in python
/nix/store/xf54733x4chbawkh1qvy9i1i4mlscy1c-python3-3.10.11/bin/python3: error while loading shared libraries: __vdso_gettimeofday: invalid mode for dlopen(): Invalid argument
Has something else been changed today?

@clarkee1066 I responded to your other post but I’ll put it here as well for closure:

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.