My replit is not saving and my client is telling me to quit replit

And he’s right. We’re using github for our project and replit won’t save, the cloud keeps blinking. Please find a solution now, I’m paying replit subscription for nothing now. Please fix asap.

Are you sure your internet connection is OK?

Yes it is. I also tried saving using the mobile app. Same thing.

First type kill 1 in the Shell tab, which can be found under “tools” just below the files pane, and if that doesn’t work try forking your repl after copy-and-pasting your code (backups are always appreciated)


Thank you! It worked! But does this mean I’ll have to kill it everytime I want it to save?

It shouldn’t require a kill 1 to save everytime. But if it keeps getting stuck saving, then you might have to.

1 Like

I woke up to everything being deleted from the repl…

This is super odd and it seems that many other users are also having this problem. If I had to guess, this could have to do with Replit’s new storage system, but I honestly have no idea why it would be deleting files from Repls.

Do you remember the names of your lost files? If so, try making new ones with the same name, which might restore their contents. If it doesn’t restore them, I would email or wait for a staff member to repond here.