My repl wont stay on for even 5 seconds

Problem description:
After running my Repl (it takes 5 minutes to start up!) it will stay on for 3 seconds before a message in the bottom right corner of the screen says “Reconnecting…” and my Repl stops. This has been happening for several days now and I can’t even view the product of my code. I know this isn’t a problem with my internet since I can stream 8k video while using a VNC to view another PC and play multiple online games simultaneously with no latency. There are no restrictions set up in my router to prevent Replit from working correctly. I know it’s not my code because when the Repl does work, it gets past the one and only quit() in my code and outputs as expected. It continues to work normally until the webserver starts up. The first request comes in (the web view opening up) and it returns 200 as normal. Then the Repl just stops working. Also, I don’t think this is supposed to happen:

Expected behavior:
Repl stays on so I can test it.

Actual behavior:
Repl stops and doesn’t give me enough time to test my program.

Steps to reproduce:
Click run and wait.

Bug appears at this link:
https://replit.com/@joecooldoo/Forum-Template

Browser/OS/Device:
Google Chrome/Windows 11/Lenovo IdeaPad 1 14IAU7

1 Like

A ton of my Repls have also not been starting up properly. (the HTML/CSS/JS ones)

1 Like

Can you run kill 1 in the shell?

1 Like

Tried that several times. The Repl kept disconnecting when trying to do it.

2 Likes

Can you try forking the repl and see if the forked version works?

2 Likes

Ive already tried everything, including:

  • kill 1 in Shell
  • Fork Repl
  • Rename Repl
  • Stopping Repl, Waiting for About an Hour, then Starting It Again
  • Clearing Cache
  • Hard Reload
  • Restart Chrome
  • Restart PC

But the Repl still wont work.

2 Likes

Try forking this repl and running it.

1 Like

I saved a recording of the bug happening:

2 Likes

This is still happening to me and I cannot edit my Repls.
I can run it once, but then it will not work again.

here it is a prblem repit is having recently.
https://status.replit.com/notices/o70zunri9sggfwmu-repls-may-take-longer-than-usual-to-boot-up

1 Like

It WILL boot, see my original post.

Also, this problem I’m having has been happening longer than that issue has even existed.

Hey @joecooldoo!

We cannot reproduce the issue, nor do we see any errors in our logs for your Repl. As soon as the disconnection happens, can you please send us the time and date (using the UTC timezone) so we can pinpoint the moment in our logs to dig deeper?

1 Like

2023-07-08T05:15:00Z
July 8, 2023 @ 5:15 AM
It happened again.
The time above is in UTC Time.

Thank you, we will look into this.

I think I found the issue in our logs. I have escalated this to the team and will let you know as soon as we have an update.

For accuracy, would you mind replying below of more UTC timestamps whenever the issue happens, so we can crosscheck and ensure that we are looking in the right place?

1 Like

PS: If you change your server location in https://replit.com/account to the Asia cluster, does that solve the issue?

I will check next time I encounter the problem.

2 Likes

It happened again at 2023-07-12T22:13:00Z
Changing the server location to Asia does seem to fix the issue.
But then things get much slower probably because I’m farther away from the server.

EDIT: And again at 2023-07-12T23:07:00Z

uGh, I added a new feature to my Repl and it all disappeared with a tap of the run button. I lost 3 hours’ worth of work because of this. I’m getting really frustrated.

1 Like

That sounds bad…were you on Asia server for it?