My repl using pygame is not recognizing output as an available video device

Problem description:
My repl using Pygame is not recognizing output as an available video device.

Expected behavior:
uses the output as a video device

Actual behavior:
The output section just has a loading wheel that never goes away

Steps to reproduce:
This probably has to do with a current repl VNC boot issue so just make a pygame repl that utilizes screen output

Bug appears at this link:
It is a game that I am working on so I would prefer not to share the link


1 Like

I believe that I am having the same error. On Friday I had code that worked correctly with pygame. Today, a wheel spins while it loads and then it says.
pygame.error: No available video device

We are seeing the same issue. I have two different replits that we have been working on for months. Suddently they cannot find the video device.

Note that for me it is only happening on replits in a “team”.

for me it is happening for all of my repls

This is a known issue.

(my repls that use output)

yes i am aware of this