My Repl Renders Absolutely nothing

For reasons unknown, my repl has stopped rendering anything. Zero. Zip. Exactly zero HTML.

It’s a private one, so I’m not sure if you can see:

https://nickblog.nickhodges.repl.co/

The website runs just fine when deployed.

Are you hosting it, or using the Replit HTML template?

1 Like

It won’t run in the replit site at all in the Webview pane or in the browser if I copy the link there.

1 Like

Are you using the HTML/CSS/JS template?

1 Like

I am not. It is a nextjs project.

Note that it was working wonderfully, and suddenly stopped working.

1 Like

Could you send the code?

No, I’m sorry – I can’t.

This is not a coding issue – the code works fine. The WebView inside replit is failiing.

Try forking the repl, and running the forked version.

3 Likes

That’s a good idea. I’ll try that.

2 Likes

Also, you could try running kill 1 in the shell.

3 Likes

Hi @NickHodges,

I would just like to clarify, is this a problem with the Webview, and does opening the website in a new tab fix this problem?

If so, I believe Replit Staff released a fix for this a while ago, but I remember some users still having problems even after. It may be needed to elevate this to Replit Support.

1 Like

No, it happens if I copy the URL to a “regular” browser window as well.

1 Like

I tried to open the website in a new tab, and it did appear blank for me. I’m not 100% sure if this is because it’s private or because of your problem. Could you try visiting your site and pressing CTRL + U (opens view-source tab)?

Actually, there may be another way to check if something like this is happening. I’m not very experienced with Inspect Element, but I believe the Network tab may be able to help troubleshoot why the code doesn’t seem to be syncing. It lists all connections your website might have made, which could be contacting Replit servers for all the required assets.

Yep, I did a View Source and there is nothing there. Zero HTML.

1 Like

I don’t think I’ve ever seen anything like this. Could you try navigating to a page on your domain that doesn’t exist? (ex. https://nickblog.nickhodges.repl.co/randompage) There should be a 404 page IIRC

Same thing – exactly zero text. Nothing. No 404 page…

1 Like

Well, I honestly have no clue what this could be about. Maybe try pressing Run, but that most likely won’t fix anything. I would contact Replit Support and see if they have any solutions.

Okay – thanks. I’m very grateful to you for looking into it.

2 Likes

Hello @NickHodges

I’m assuming that there are no errors in Replit console. Can you check in the inspect element console? These are just some random ideas. I tried some random things like going to https://nickblog--nickhodges.repl.co/ and that too is blank. Inspect Element is blocked on my chromebook but a source code viewer isn’t. Weirdly, I got this on that site:


Maybe that means the site isn’t loading so the output is blank or something.

Also, maybe try going to history on the file you last edited before this error, copy the current code and maybe go back a day or so because that could fix it. (Maybe try that on other files too)

Quick question, run echo $REPL_ID in shell and you should get a bunch of random characters. go to [that output].id.repl.co and if that too doesn’t have anything then the repl could just be broken (could be fixed by a fork or downloading all the files and uploading them. Note to not upload the config files or folders, just your files). I could get this ID myself but you did mention that it’s a private repl so I can’t. I’d also try forking but it’s private.

What was the result? Also did you try the kill 1 command?

Try this if that id thing doesn’t work: just download all the files and upload them on a different repl so the config files are different but the code is the same. Please share the results of anything you tried.

2 Likes