My repl got corrupted... twice

So umm basically I opened my repl (YouTube in the console) earlier today and all the files had been deleted, even the .replit and replit.nix files. I am 100% sure I did not do this intentionally or accidently, since it was like this when I started it up, and there are forks from after I had last been on it (which was May the 3rd) which had no deleted files, and some that did, which means it happened at some time I was not using it. I used some GQL to find the time certain forks were created and I can deduce that it was corrupted on the 4th of June, somewhere between 6:42 and 23:27 (thats in GMT, btw)

This next part isnt really a bug, but I tried to fix it by moving the files over via zip, and it was large enough (43 MB, but I uploaded it three to four times in frustration) that I eventually closed the tab again because of frustration, and I imagine I corrupted it for a second time and now the repl wont boot up any more so I can’t do anything.

I can start again in a new repl to fix this but my original repl is the one that people will find because it is the most popular, so while I can link a new one, I’m pretty annoyed by this and I would like to know why this happened.

Thanks for reading

30 minutes of waiting for it to boot later, it actually started up. However, poetry (and therefore packager) is no longer working and I’ve tried importing the files manually but it just wasn’t working, so I’ve put the code in a new repl and it works fine, but it’s very annoying for people to have to redirect themselves and I’m still interested into why it corrupted in the first place

What’s the error? Is it something about requests? Or maybe an HTTPResponse thing?

Hey @Classfied3D!

I am very sorry to hear that you have lost your data. I have sent this to the team as a high-severity issue and will let you know as soon as I have an update!

We couldn’t find any evidence of data loss from the Repl in your screenshot. Would you mind sending us the link to the Repl where the data loss occurred?

Try renaming a file with the same name you had previously???

Maybe you ran out of storage?

And then it glitched because i was taken by a AI who loves storage.

Yes, that is what I thought might have happened because it downloads videos in order to play them. However it is not a server repl and I was not using it so I’m not sure how it suddenly ran out of storage

I renamed the repl and created a new one with the same name btw. The one that lost its storage was

That’s the error when I try to install/uninstall something

Try this on any files that permission is denied to:

chmod 700 file/location

In this case:

chmod 700 venv/bin/python3

The same happened to me too, my repl Mario-Updates was a Mario Clone and the source code of it literally changed to a discord-bot repl. The repl’s code was not written by me or forked by me.

EDIT: The issue is not fixed

Thanks, but now I get this error

What do you mean by this?

The issue is not fixed and the repl is corrupted to this day.

Try editing the pyproject.toml to say that python 3.9.6 is okay.


  • Find where “>=3.8.0, <3.9” is
  • Replace it with “>=3.9, <3.10

Same error just without the warning

oops forgot to reply @Firepup650

EDIT: also I just noticed

That was not happening before

Huh. What does running ps -A in the Shell show as running? Also, try adding packages using poetry directly instead of Replit’s package tool.

Im getting storage errors now

I have no idea where all the storage is being used