My project is failed after the environmental update

I fork the Tradingview to Telegram bot from this link

It works until the auto environmental update on last Friday. I have no coding knowledge please help me. Thanks

Traceback (most recent call last):
File “”, line 1, in
import server
File “/home/runner/ttmw-tgtest-25may2023/”, line 1, in
from flask import Flask, request
ModuleNotFoundError: No module named ‘flask’

I’m assuming that this is the repl.

You’ve got to go to the “Shell” tab, and type “pip install flask”.

Hope this helped :slight_smile:

Thanks for your kind advise, yet it doesn’t fix the error.
An error occurred during configuration: option use-feature: invalid choice: 'content-addressable-pool' (choose from '2020-resolver', 'fast-deps', 'in-tree-build')

This is the Replit


Try using this command:

pip install --no-use-feature=content-addressable-pool flask

It still states the same error. Is there any way to fix this ?

Thanks for your king help.

Hmm, can you go to .config/pip/pip.conf and delete the option content-adressable-pool if it exists?

And also, these nix migrations are so buggy, I’d recommend downloading your code and uploading it in a new repl.


Would work (I think), except pip config errors are fatal. You have to edit the file by hand to fix these. ¯⁠\⁠_⁠(⁠ツ⁠)⁠_⁠/⁠¯

1 Like

Hi, I had the same thing happen now to 2 projects after they were ‘updated’ to nix projects.

I’m sure this is not the most elegant solution, but what I’ve done that has worked in both cases was to rename the pip.conf file in .config/pip/ to another name. (I simply added a prefix to the file name, for example: NOPE-pip.conf.)

This makes pip ignore the file and use it’s default configuration, which in my case resolved the issue.

By renaming the file, it remains available, should there be a need for it in the future, but it is ignored by pip which then runs as expected without the gibberish-y error message.

My project also failed after the environmental update, exactly like yours! Its so annoying. I had to create a completely new repl and then create the files by hand and copy and paste everything in. Thats the only way I got it back working.

I tried this, but unfortunately it didn’t work for me.

I have a similar issue with all my repls. I can’t use pip to install any missing modules. I wish they never changed it.

Is it an invalid configuration error? If so, try:

I can download libraries with pip now but selenium is still broken. This is the error that happens now:

Traceback (most recent call last):
  File "", line 8, in <module>
    driver = webdriver.Chrome(options=chrome_options)
  File "/home/runner/Selenium-Template/venv/lib/python3.8/site-packages/selenium/webdriver/chrome/", line 84, in __init__
  File "/home/runner/Selenium-Template/venv/lib/python3.8/site-packages/selenium/webdriver/chromium/", line 101, in __init__
  File "/home/runner/Selenium-Template/venv/lib/python3.8/site-packages/selenium/webdriver/common/", line 100, in start
  File "/home/runner/Selenium-Template/venv/lib/python3.8/site-packages/selenium/webdriver/common/", line 113, in assert_process_still_running
    raise WebDriverException(f"Service {self._path} unexpectedly exited. Status code was: {return_code}")
selenium.common.exceptions.WebDriverException: Message: Service /home/runner/.cache/selenium/chromedriver/linux64/113.0.5672.63/chromedriver unexpectedly exited. Status code was: 127

This has happened before, try:

1 Like

Still doesn’t work. After doing Ctrl + \ in console, it just quits & dies unexpectedly:

 SIGQUIT: quit
PC=0x7fc747ce2ff9 m=0 sigcode=128
signal arrived during cgo execution

goroutine 1 [syscall, locked to thread]:
    runtime/proc.go:250 +0x212 fp=0xc000067fe0 sp=0xc000067f80 pc=0x438c92
    runtime/asm_amd64.s:1594 +0x1 fp=0xc000067fe8 sp=0xc000067fe0 pc=0x465041

goroutine 2 [force gc (idle)]:
runtime.gopark(0x0?, 0x0?, 0x0?, 0x0?, 0x0?)
    runtime/proc.go:363 +0xd6 fp=0xc000054fb0 sp=0xc000054f90 pc=0x439056
    runtime/proc.go:302 +0xad fp=0xc000054fe0 sp=0xc000054fb0 pc=0x438eed
    runtime/asm_amd64.s:1594 +0x1 fp=0xc000054fe8 sp=0xc000054fe0 pc=0x465041
created by runtime.init.6
    runtime/proc.go:290 +0x25

goroutine 3 [GC sweep wait]:
runtime.gopark(0x0?, 0x0?, 0x0?, 0x0?, 0x0?)
    runtime/proc.go:363 +0xd6 fp=0xc000055790 sp=0xc000055770 pc=0x439056
    runtime/mgcsweep.go:278 +0x8e fp=0xc0000557c8 sp=0xc000055790 pc=0x4260ee
    runtime/mgc.go:178 +0x26 fp=0xc0000557e0 sp=0xc0000557c8 pc=0x41afa6
    runtime/asm_amd64.s:1594 +0x1 fp=0xc0000557e8 sp=0xc0000557e0 pc=0x465041
created by runtime.gcenable
    runtime/mgc.go:178 +0x6b

goroutine 4 [GC scavenge wait]:
runtime.gopark(0xc000030070?, 0x50d320?, 0x1?, 0x0?, 0x0?)
    runtime/proc.go:363 +0xd6 fp=0xc000055f70 sp=0xc000055f50 pc=0x439056
    runtime/mgcscavenge.go:389 +0x53 fp=0xc000055fa0 sp=0xc000055f70 pc=0x424193
    runtime/mgcscavenge.go:617 +0x45 fp=0xc000055fc8 sp=0xc000055fa0 pc=0x424765
    runtime/mgc.go:179 +0x26 fp=0xc000055fe0 sp=0xc000055fc8 pc=0x41af46
    runtime/asm_amd64.s:1594 +0x1 fp=0xc000055fe8 sp=0xc000055fe0 pc=0x465041
created by runtime.gcenable
    runtime/mgc.go:179 +0xaa

goroutine 5 [finalizer wait]:
runtime.gopark(0x5a82c0?, 0xc000007860?, 0x0?, 0x0?, 0xc000054770?)
    runtime/proc.go:363 +0xd6 fp=0xc000054628 sp=0xc000054608 pc=0x439056
    runtime/mfinal.go:180 +0x10f fp=0xc0000547e0 sp=0xc000054628 pc=0x41a0af
    runtime/asm_amd64.s:1594 +0x1 fp=0xc0000547e8 sp=0xc0000547e0 pc=0x465041
created by runtime.createfing
    runtime/mfinal.go:157 +0x45

rax    0xfffffffffffffffc
rbx    0x0
rcx    0x7fc747ce2ff9
rdx    0x0
rdi    0x1
rsi    0x7fffa31dc770
rbp    0x0
rsp    0x7fffa31dc6e0
r8     0x0
r9     0x0
r10    0x0
r11    0x246
r12    0x0
r13    0x0
r14    0x7fffa31dc770
r15    0x0
rip    0x7fc747ce2ff9
rflags 0x246
cs     0x33
fs     0x0
gs     0x0
repl process died unexpectedly: exit status 2

What command(s) did you run to generate that error?

1 Like

Hi, guys!
Who can help solve the problem here or write in a telegram (describe it step by step):

Traceback (most recent call last):
  File "", line 1, in <module>
    import server
  File "/home/runner/TradingviewWebhookBot/", line 1, in <module>
    from flask import Flask, request
ModuleNotFoundError: No module named 'flask'

Special thanks if you write to me in telegram @redheeid

@qqqqqqqqq88qqq @vtkuntanut Just run poetry add flask in the shell. pip install flask is less compatible with Replit because Replit uses poetry for package installation.

1 Like