My project does not work when downloaded and run on windows. Why is that?

Why i port my project to windows from replit, it first returns that the gingerit module is not present, although it is. it also has more errors in different places. is there a reason for this?


Could you please include screenshots of the errors that Windows throws when running your program?

1 Like

Currently I can’t as I am away from and using a chromebook. I will be able to send screenshots in 4-6 hours. Sorry about the delay!

1 Like

The only error I can remember was the gingerit module not found error.

Perhaps you forgot to install the necessary packages on your computer?

When you download your project from a repl environment that already has the existing libraries installed, it does not install them as well. To correct this, simply reinstall the libraries onto your device.

1 Like

I tried reinstalling them but windows said there was no pip command. I am not an administrator on my computer and downloaded python from the microsoft store. Could this be a contributing factor?

1 Like

Just to be sure, reinstall pip to the path.

How would I do that. I’m sorry if this question is stupid but I have always used Replit, as it was what I started on. Thank you!

Download the Python 3.10 installer here:

Will this require admin privileges? I am no an admin on my computer.

I believe that installing python requires administrator permissions.

1 Like

I know, but the version of python off the microsoft store does not require admin privileges.

I reinstalled python because I didn’t have pip.
Here are some of the error I recieve:

It says it isn’t present even though it is. I ran pip install again but it still failed.
I can’t find anymore errors because the entire project require customtkinter

What error do you get with pip?

Try importing tkinter instead of customtkinter.

customtkinter is slightly different from tkinter, breaking the code. I’d have to replace every function to get it working.

I used to have an error but I reinstalled python all together and it worked.

^ Was what I meant, what did pip spit out?

it said requirements were satisfied, as if you ran pip on something you already installed.