My domain has linked successfully yet, I am still getting SSL errors

I have noticed that when going to my website I get SSL errors (ERR_SSL_PROTOCOL_ERROR) and I am unable to connect to my website. On the replit “Domain Linking” tab it says the domain is linked correctly. I tried to unlink and relink my domain. I am now unable to link my domain with www to replit only the domain without www and even though it says the one without www is linked, it is still showing SSL errors.

I am using for the dns and I know I have the CNAME and TXT records set up correctly.


I know this is a confusing post but please ask me questions to help, I will answer them as best as I can. I’m really stuck on what to do, if anyone could provide answers for what I am doing I would be really grateful. Thank you!

Try using http:// instead of https://. I think there is some SSL bug but idk, check

Maybe it is a propagation thing, because I’m able to access your website (www and non-www) with no issues whatsoever.

I managed to fix it last night. When speaking to the DNS provider they had asked me to try and add the A record from the replit CNAME and that worked.

1 Like