My app is wrongly marked as VNC and I am unable to deploy

I was running a flask app (uses matplotlib for generating graphs). It used to be deployed. but after a pause, when i tried deploying again - i am getting a “cannot deploy VNCs”

try after you run in Shell

pkill -1 Xvnc

and refresh the page. In the sidebar, click ⋮ > Show hidden files, and add to the .replit file:

localPort = 5900
externalPort = 5900

this might prevent it from interfering with your webserver


It hasn’t helped.

To be clear - the webserver is running fine - only the deployments feature is not working.

I am hosting a pretty standard discord.js v14 bot on replit. Every time I try to deploy it, it says VNC deployments are unavailable. I know what VNC is, but there is no way my bot includes VNC or has any features similar to it. Has anyone else had any problems? Is there a known solution?

There’s already a topic for this issue. It hasn’t been solved, but maybe you could try Umar’s reply?


Thanks for the reply, sadly the reply didn’t work, but it is good to know that it is a know issue.

@JessoClarence @WrigglySplash I believe this issue has been fixed now, can you try re-running your Repl, then try to deploy again?

thanks for the heads up - i ended up forking and deploying a new version.

The issue doesn’t seem to be fixed for me. I saw someone mention that they forked their project and ran the fork. I tried this and it also doesn’t seem to fix the issue. Not sure what’s so different about mine that this problem keeps happening…

Weird. I can pass this along if you provide a link to the Repl and/or a Repl ID.