Moving stuff in a ubuntu os

so this isnt directly related to replit but i know alot of smart people are on here and i use a linux ubuntu running machine to store a minecraft server and when untaring a file it put the data in a folder and i was wondering if anyone had a command to get the file out of the folder without having to manually donwnload and move each file

You should just be able to use mv:

mv source/file.ext target/newFile.ext
1 Like

yeah thats the thing i dont exactly know how to phraise it its stored in pterodactyl in /home/container/(the untarred file name) so would i just do mv (folder name) target(/home/container)?

1 Like

Is it currently stored in /home/container, or is that where you’re trying to move it to?

1 Like

its in /home/container/foldername i want it to be in /home/container

i want all the contents of the folder to be moved to the /home/container cause there is alot of files in it its a whole minecraft server

1 Like

mv folder/* target
I tested this in a Docker container and it worked until I moved the mv command to the wrong folder.

so if i do mv /foldername /home/container?

mv /foldername/* /home/container should move everything in foldername to /home/container I think. * is a wildcard.

im checking to see if posible to move them out of the folder as i use pterodactyl and it has a gui and there is a move option but i dont exactly know what to put threre to get it to drag the files out

Do you have a GUI on your server? You could just use the GUI file manager (Linux has lots of them).

its ran through pterodactyl idk if you know much about that

1 Like

I don’t know much about pterodactyl but I’m familiar with Linux OSes.

ah idk what to do ever since i untarred the file its been being so weird and i dont know what the cause of it is

i did it via ssh i used mv /foldername . and it worked

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.