Mobile View in Firefox on Linux

Bug description: I am getting the mobile view as default when using Firefox on Linux. It is fixed by holding Shift while refreshing the page, but will go back to mobile view on reload/refresh.

Expected vs Current Behavior: Should always get the desktop view instead of mobile.

Steps to reproduce: Open the page or click refresh.

Bug appears at this link: https://replit.com/@jfftck/TallOffbeatCommunication#Main.hs or any other project.

Screenshot(s)/Screen Recording:

Browser/OS/Device: Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/117.0

Replit Profile: https://replit.com/@jfftck

Is this your user agent string? If not, please paste it from useragentstring.com.

Yes, and I tried Chrome User Agent string and it too defaulted to the mobile view, so it doesn’t look to be switching on that.

1 Like

That’s interesting. Could you try shrinking the window and/or your screen or making it bigger?

Also try looking for a browser setting related to Desktop/Mobile site? Perhaps some emulator extension you have or something (unlikely though)

I tried it on my ultrawide and my laptop monitors and the same result, I will try seeing if it is an extensions later.

1 Like

Have you tried different accounts too? Maybe it’s a hidden setting that somehow didn’t turn off after you left a mobile device.

So, this is probably not true, but it COULD be that, maybe it’s detecting Linux and assuming that it’s a Chromebook. Chromebooks are built off of Linux, but they also have the Google Play Store, meaning you can download the Replit app. So perhaps it could be thinking you’re on that kind of device? Just a thought, this is unlikely but also a possibility

Jfftck,

It looks like this Repl has been deleted. Could you provide a link to another with the same issue? I was able to use your User agent string but was unable to recreate the issue. If I could see it on a live Repl I may be able to get further. Thanks!