Mobile keybind not respected

Problem description:
Using mobile device iPhone with a connected bluetooth keyboard to type my code. In a repl I usually use on my laptop/desktop I have the keybind setting set to VIM. This isn’t respected when using the phone instead I have the default settings.

This also made me realize when I was using the phone with soft keyboard it uses the default keys but the setting is set to VIM. So in retrospect it should’ve been having the VIM keybinds but it’s using default regardless what is set under the keybind setting drop down.

Expected behavior:
I expected to have VIM keybinding functionally as I would when on a laptop/desktop Repl to write code.

Actual behavior:
I begin to write code but it has the default keybind behavior regardless of the keybind setting.

Steps to reproduce:
Connect a Magic Keyboard - US English, official from Apple, to iPhone.
Go to open up some code in Repl and start typing.
Check settings and change the keybinds then write some code
Are the changes being respected?

Bug appears at this link:

Device: iPhone 13 Pro
iOS 16.1.1
iOS Replit 2.24.0

1 Like

Are you using the Replit mobile app or the web-based IDE?

I am using the Replit iOS(16.1.1) mobile app, version 2.24.0

Our mobile engineers are quite busy at the moment, so unfortunately I can’t tell you when this will be completed. Will update you when a fix is implemented.

I understand, when any updates do come I’ll be here patiently waiting :man_in_lotus_position: Thank you.