Missing hidden files (.replit, replit.nix)

I have been programming a discord.py bot in replit, and it has been running fine for the past few months. But in the past few days, the following error message showed up and prevented me from running it:

“Run isn’t configured. Try adding a .replit and configuring it https://docs.replit.com/programming-ide/configuring-run-button

Under hidden files, there are no files named .replit or replit.nix. I tried to add a .replit file with the line " run = “bash run_button.sh” ", and in the file run_button.sh, “python main.py”. When I again tried to run it, the following error message shows up:

“ bash run_button.sh
run_button.sh: line 2: python: command not found
exit status 127”

Here is the link to the project: “https://replit.com/@traffyboi/Slime-bot-for-DC

Any advice in helping to fix the issue are greatly appreciated.

Hey @TonyCen welcome to the forums!

What might be the problem is adding those files into the secret files category you can access those by clicking on the three dots on the files text. If there aren’t any hidden files there make another Repl in the same language and download those hidden files and put them into your main Repl. I hope this helps :grin: ! If you find this to be the solution to your problem please mark this as the solution to the post.


Thank you very much. However, another problem I am experiencing after carrying out your said steps is that, when I click on the run button afterwards, my replit is really slow and unresponsive, with no running messages in the console.

@TonyCen it is probably due to the amount of files you have and the space that Repl’s have for them. I would recommend but the files together to reduce the amount of thinking Replit has to do.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.