Markdown not loading

I have two issues.

  1. Many students are complaining that the instructions tab does not open. When I asked them to open it manually, they mentioned that they didn’t even see the option to open the instructions tab when they click +, neither they see it under tools.
  2. The Markdown option has stopped working as well. Keeps showing the loading animation when I click on Markdown. The instructions tab is open.

Hi @patilsandeep , welcome back!
The Instructions tab is a bit buggy, and may take a while to open.
Can you try pressing CTRL+SHIFT+R to refresh the cache and the page?

Students tried it even in a private window, with no luck.

1 Like

@patilsandeep Can the student try forking the repl and see if the forked version works?

How can they do that?

They can click the Fork button:


They don’t see that option. This is Teams for Education I am talking about. They don’t even see that publish option. I don’t think they are supposed to see that, by design. If they fork, then it goes to their own replit and outside of the teams and then I as a teacher cannot access their forked repl.

image

Hm… maybe @ShaneAtReplit (sorry to ping) can take a look at this? I think there’s a similar report:

Bug description:
Markdown file failing to load. The Readme file itself and previous works but the markdown option to open as always been separate

Expected vs Current Behavior:
The markdown tab should display the information from the markdown file. It is not loading anything at all

Steps to reproduce:
Opening any team, or any task the markdown file isn’t working.

Bug appears at this link: https://replit.com/team/cydeofall2023
But has been for all teams seems like

Screenshot(s)/Screen Recording:
image

Browser/OS/Device: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/117.0.0.0 Safari/537.36

Replit Profile: https://replit.com/@ssajjad1

Hi @ssajjad1 , welcome to the forums!
Can you do a hard refresh of the page by pressing
CTRL+SHIFT+R?

I tried, but that didn’t do anything.
This is not a local issue. It is happening to all my students across multiple teams.
It is something on the repl side

Hey @patilsandeep!

Can you please send me the link to the Repl that you’re having issues with? Also, is this happening to all of your students or only certain students?

Also, the topic linked above was fixed here, so maybe the fix will resolve this one:

I believe that topic is different - that other topic is when the teacher is editing a markdown file. This topic here is about the Instructions tab for the students when they start or open a task. I believe it might be the same as this one:

Problem description:
Markdown worked all right a week ago, but now does not load in the window placed on the right to the code editor.

Expected behavior:

Actual behavior:

Steps to reproduce:

Bug appears at this link:
5_0_Button_Farbe - Replit

Browser: Same issue with Chrome, Firefox abd Edge
OS:
Device (Android, iOS, NA leave blank): Same issue with Window Computer and MacBook
Desktop app version (Avatar menu->“Version”) or NA:
Plan (Free, Hacker, Pro Plan): Free education

The topic @ShaneAtReplit linked was the same as the second bullet point of this topic, at least.
The issue there at least is that the Markdown tool is still listed even though it was replaced by the feature of previewing individual files using the eye icon next to their filenames.
(To preview a file while editing it, open your file in a tab in another pane and hit the eye icon in that tab)

1 Like

Ok, I found a solution to this problem by choosing the preview option of the markdown tab above the editing window. This makes appear the lessonplan in the main window where the students can now choose between the lessonplan and the coding. Not perfect, but works for me.

I sent you a direct message, did not want to publicly share non-public links.

Thank you, the preview button works. But, yes, the main issue is students cannot see the instructions tab, nor does it open automatically, and the option to manually open it has also disappeared. What bothers me is this is not all the students, only some. I have to now go to all the projects and make instructions files as part of the project so that students can meet their deadlines.

Thanks, I will take a look!