Login credentials not accessible from iOS mobile app + unable to send feedback from Replit IOS mobile App (when not logged in)

Problem description:
I’m travelling and didn’t have my 2FA available for my account that I use with Replit. I wanted to login and use the mobile app (iOS iPhone Pro 14, recently updated) and selected Google Social option. However, none of my device, browser signed in accounts were available. It was going from an empty namespace asking me to login again from scratch. However I didn’t have my 2FA with me (and my account has hardened security options / no in-person available back-ups.

The next step was sending a bug repot directly from the mobile app. I filled out the details. And even added a screen shot. No matter what I did, the “send feedback” button remained disabled and I was unable to send in the details from there. Not sure if this is for logged out accounts only, or the feedback from mobile app button is broken on iOS.

Expected behavior:
I could login using available device or browser social accounts from google that are already logged in rather than logging in from scratch (high-friction). First-party context available for use.

I can send feedback from the mobile app when not logged in.

Actual behavior:
They both didn’t work

Steps to reproduce:
Click login to replit from the iOS app.
Select send feedback from the replit mobile app when not logged in.

Bug appears at this link:
iOS mobile app.

Browser/OS/Device:
iPhone Pro 14
Chrome as default browser (but not related).

1 Like

To log into the mobile app, you must first be logged into the replit website. Try out these steps and see if they work:

  1. Open your default browser
  2. Go to https://replit.com/login
  3. Hit “forgot password” and enter your email
  4. Check your email for a confirmation link and follow the steps to reset it
  5. Log in via email/password

After those steps, you should be logged into the replit website. Next, you can:

  1. Quit and reopen the mobile app
  2. Hit “Log In”
  3. You should be able to log in successfully without filling out any additional details.

Please let me know if that worked and if you ran into any issues. Thanks for reaching out!

1 Like

Does the Replit app use SSO, just like this forum?

1 Like

@ShaneAtReplit was the one who built the login mechanism for the ask forum. To be honest, I really am not sure.

1 Like

The Replit app uses a different system. Discourse has their own SSO mechanism which I’ve implemented into Replit: Setup DiscourseConnect - Official Single-Sign-On for Discourse (sso) - admins - Discourse Meta

1 Like

Well, thank you to @ShaneAtReplit for this mechanism, it helps to verify if people put fake replit usernames!

3 Likes