Loading issues - stuck on light loading screen

On edu Teams half of my class cannot load HTML or python projects. We have had the widespread issue for week where the loading screen hangs in light/white mode - but pressing f5 will reload it in dark mode and seconds later the project loads fine. This morning the issue will not fix. We have tried other browsers and cleared cache.

1 Like

Picture of the console of one of my pupils when stuck on the light mode loading screen.

Hi @CompSciAdams !
Are you using normal Replit or Firewalledreplit?

Normal - as far as i am aware. Most of the class can access as normal - its just a few pupils with this issue.

@CompSciAdams Do you think it could be because of a firewall?

No, as I said most pupils can access it and they are all on the same type of user account and on the same network. It could be random or could be due to something on their replit account.

Could you send a picture of the HTML page with the bug?

I’ve got a new class in and most of them cannot access any replit projects. Still can’t figure out what they have in common - but its the same error in the console as pictured here.

Pupils are using chrome v118 and v119. Same issue occurs on MS Edge.

We have spoken to other colleagues and the issue is occurring across the country,

The console errors are throwing this when the refresh flips to the write loading screen. Its occurring on mobile app too. wss://eval.teams.replit.com/wsv2/v2.public.
MicrosoftTeams-image (6)

Our IT network support team have confirmed that replit and darkly are not blocked on our firewall - so looks like the issue is on Replit’s end.

Many of my students are experiencing the same issue. They’ve tried using different browsers and Wi-Fi networks but are still getting stuck on the loading screen.

Try adding #main.py to the end of the URL. This has worked for me with the same problem.


First post to say we are having the same issues here and similarly time for workrounds is not really an option. We’ve tried adding #index.html to the end for Web projects but that just still gives the same result.

1 Like

Adding #index.html has worked in many cases for me and my classes - but not all. For those who still can’t open projects I just logged in for them as it would appear that teacher/admin accounts never have the issue. Clearly not a long term solution but i actually got through my lessons today.

1 Like

We are having the same issues and working with Java. Adding #Main.java doesn’t seem to be working. Students can’t even create a Repl outside the team.

Replit is working on this.