Libuuid.so.1 not found error when using azure.cognitiveservices.speech sdk

Question:
I’m using the azure.cognitiveservices.speech sdk and getting the following error:
OSError: libuuid.so.1: cannot open shared object file: No such file or directory

I’ve tried the following:

  1. add pkgs.libuuid in replit.nix and updated LD_LIBRARY_PATH\
  2. installed binutils via packages
  3. trying to install libuuid or python-libuuid via packages but those are failing with libuuid/_uuid.pyx:4:8: 'uuid.pxd' not found when the cython script does a `cimport uuid

there are no google searches for that last error! haaaalp!

Repl link: https://replit.com/@syncopatedtime/voicetest-2?v=1

Could you try uninstalling and then reinstalling everything (or use a new repl), but install only using the Packages tab?

1 Like

Tried that too, hence the “-2” suffix to this repl :slight_smile:

Quick question, is Explorer mode on in your profile? There might be some new recent features that are supposed to fix shared library installation.

Try installing libuuid with the System Dependencies tool (might be the same).

This should work:
Set PYTHON_LD_LIBRARY_PATH instead of LD_LIBRARY_PATH (or set both).

This worked! Thank you!

More specifically, setting PYTHON_LD_LIBRARY_PATH fixed the issue

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.