Jupyter Notebook on Replit -- unable to install package

I don’t want this to be too long.

  1. Jupyter installed and connected through SSH so I can use through my browser - OK
  2. I still have some uncertainty about correct way to make this available - at moment it is to run in Relit which, of course, looks at Requirements.txt
  3. I can install the package I am interested in (openai) both with pip install --user openai in the shell within my virtual environment
    and from the Notebook with !pip install --user openai (just to see if that helps)
  4. I have selected the virtual environment (with fancy name env) in the Notebook
  5. I have modified the PYTHONPATH var and exported it in the virtual env of shell so that it also has the directory path to that package
  6. I have done similar in the Notebook
  7. If I run in the shell
    (env) ~/Jupyter-Notebook-Openai$ pip show openai
    WARNING: Package(s) not found: openai
  8. If I run in the Notebook
    !pip show openai
    WARNING: Package(s) not found: openai

Any ideas?
I suspect this has to do with Nix which I just don’t understand - it’s new to me.

edit replit.nix and add the desired package. Save and re-run.
This file is hidden example:

{ pkgs }: {
	deps = [