Java program with folders won't compile

Hey folks! I have a java program that I am attempting to compile and run. I have imported the program from existing code, so I know it works. I am guessing it is an issue with the file folder structure. Here is the repl:

HERE

I have tried moving Main.java to outside the murach folder and it still will not run. Any ideas?

Hi @marklocklear can you please post a link to the repl so we can investigate?

Bump. I was able to hyperlink the repl in my original post above if someone wants to take a look.

Thanks in advance!

1 Like

maybe move all of the contents of the murach folder out. Enter in shell to do this quickly:

mv -f murach/* murach/.* .; rm -r murach

Hi,

I tried @StupidGenius 's suggestion but the same error occurred.

I forked the repl and found that the javac command worked without issue. However the main.class file is being generated in the ui folder, not the murach folder.

Can you check your code @marklocklear to make sure there isn’t an issue in Main.java?

@IanAtReplit I commented out package murach.ui at the top of main and that seemed to fix the issue with main.class being compiled in the UI folder.

Good catch!

Fantastic news @marklocklear I’m glad you fixed it. Sorry my Java was a little too rusty to suggest that fix!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.