Issues Encountered While Setting Up Flask and Resolving Dependency Conflicts

Hello, try this:
Show hidden files and open .replit file, then replace the contents with the following:

entrypoint = "main.py"
modules = ["python-3.10:v18-20230807-322e88b"]

hidden = [".pythonlibs"]

[nix]
channel = "stable-23_05"

[deployment]
run = ["python3", "main.py"]
deploymentTarget = "cloudrun"

Reload the shell. This will probably solve the pip and poetry problems. You may need to reinstall your packages with poetry install or upm install. Also, it will run Python 3.10 instead of 3.9.

2 Likes