Issues deploying https://github.com/alex000kim/slack-gpt-bot - Timeout

Question: Hello! I am trying to deploy the Crown-Chakra-Bot (private Slack Bot for ChatGPT). I am able to run the python script without issue but when I try to deploy I get a timeout error

Repl link/Link to where the bug appears:
https://replit.com/@CrossPeakZane/Crown-Chakra-Bot

Screenshots, links, or other helpful context:


code snippet
It is the GitHub - alex000kim/slack-gpt-bot: GPT4-powered Slack bot that can scrape URL contents project with API keys loaded

I appreciate any feedback. Replit told me to post here to get support!

For bots, we typically recommend Reserved VMs via Background Worker. Do you receive the same error using this deployment type instead?

Also, I noticed your Repl is private so if you make it public, then the community can take a look and test as well.

Thanks Suzy!

I have secrets in this replit. If I make it public those become public right? Thats the only issue with sharing it public.

I tried to deploy as a VM

exceeded maxrequestbatch of 4096

The project is literally the GitHub - alex000kim/slack-gpt-bot: GPT4-powered Slack bot that can scrape URL contents project with a small modification to use a downgraded of the openai library since they changed the way they make calls. Once I get the bot to work Ill work to improve it. The bot works fine when I just run the app from Replit instead of trying to deploy.

Again, appreciate the help!

2024-01-09T21:53:06Z info: Connecting to builder
2024-01-09T21:53:08Z info: Builder connected
2024-01-09T21:53:08Z info: Installing packages
2024-01-09T21:53:08Z info: Skipping Build as no Build command set
2024-01-09T21:53:09Z info: Pushing pid1 binary layer...
2024-01-09T21:53:10Z info: Created pid1 binary layer
2024-01-09T21:53:12Z info: Skipping Python layer creation
2024-01-09T21:53:12Z info: Retrieved cached nix layer
2024-01-09T21:53:12Z info: Created hosting layer
2024-01-09T21:53:18Z info: Created Repl layer
2024-01-09T21:53:19Z info: Pushed image manifest
2024-01-09T21:53:19Z info: Pushed soci index manifest
2024-01-09T21:53:26Z info: Creating virtual machine
2024-01-09T21:53:48Z info: Virtual machine created
2024-01-09T21:53:48Z info: Waiting for deployment to be ready

I see there is an active issue around deployments

https://status.replit.com/notices/fovbedszazbcglhx-temporary-deployments-logs-issue-for-some-repls

Yes, let’s take a look after we get that deployment logs issue fixed so we can get some clues. Otherwise, we’re just going to see the “Exceeded max batch request error” in the logs. We are actively working on it so I’m hopeful it’s resolved soon.

I was eventually able to deploy the bot! Must have been an issue with the environment at the time. Thank you!

2 Likes

Nope, that’s why they’re called “Secrets”.