Issue regarding connected services

Bug description:
Disconnect GitHub account does not work.

Expected vs Current Behavior:
Expect the github account to be disconnected. Although, account still shows as connected with a nonfunctional token, not allowing the re-adding of the account.

**Steps to reproduce:**Head to the link below, click on disconnect next to GitHub.
Also, none of the other buttons work either. Google, Facebook etc.

Bug appears at this link: https://replit.com/account#connected-services

Screenshot(s)/Screen Recording:

Browser/OS/Device: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/118.0.0.0 Safari/537.36

Replit Profile: https://replit.com/@HkHday

I do have a screen recording but I cannot upload it due to the new user restriction.

I wasn’t able to reproduce your issue. I was able to unlink my github and reconnect it. Please send a loom.com video if you can.

3 Likes

https://file.io/fsdBrwnfYXmY
Link to the screen recording.

Initially I tried to commit to a github repo, replit prompted the use of the saved token, but I got an error message saying it was invalid. And when I went to unlink and relink my github account, none of the connected services apps work.

I have also tried this on different browsers and devices.

Did you delete it?

I do not know how it got deleted, but I have made another link, https://file.io/exSejEUQ8PUj.
I have set the expiration for a longer time this time.
File.io automatically deletes files after one download, so maybe that’s the problem.

A few significant updates went out last week around GitHub authentication which affected the GitHub connection stuff too. Can you try disconnecting Replit from GitHub and GitHub from Reply one more time and see if it’s working again?

1 Like