Is it still not possible to update to Python 3.12?

I have a problem with nested f-strings in the current Python enviroment.

The code works fine in PyCharm, but I would like it to run in Replit as well.
So instead of changing the code, I would like to update Replit to the latest Python version i.e. 3.12.2.

Is it possible at all?
If not, when will it be possible?

Hey @replit273 welcome to the forums!

NuclearPasta0 found a solution here to update Python to 3.12

I hope this helps!

I have provided the following template for python 3.12:
https://replit.com/@NuclearPasta0/Python-312
with ONE caveat - package installation takes extra steps due to package manager conflicts.

2 Likes