Invite link to Edu Team not working

Bug description:
New users cannot join our team through the invite link. Also generating a new invite link does not solve the issue.

**This bug has been appearing on and off for months already. On some days it works, on others it does not. E.g. last week Wednesday 11th of October it did not work, then on Thursday it worked again and on Friday it stopped working again. **

Expected Behavior:
When clicking on the invite link, the user is asked to create a new Replit account by choosing a new user name and password. After creating a new account, the user is part of the Complori-Edu team.

Current Behavior:**
When following our invite link, kids are only given the option to create a new account via Google or GitHub. Even if they then create a new account through Google, they are still not a part of our team.

Steps to reproduce:

  1. Make sure you are not logged into Replit.
  2. Click on our invite link
  3. You reach a page saying you can only sign up through Google or GitHub.

Bug appears at this link:

Screenshot(s)/Screen Recording:
Expected view:

Current view:

Browser/OS/Device: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36
This issue happens across various devices and browsers.

Replit Profile: