Instructions Tab not Popping Up

@ShaneAtReplit I’m experiencing the same problem. Here is a link to my project.


I also have a student with the same issue.

1 Like

My students are also experiencing this - seems to be affecting MacOS users but not Windows, but could be a coincidence?

Thank you all for the context! We will continue to look into this and I will post an update in the thread once we know more on the issue.

My students are having the same problem as well. not showing up. They tried creating a new account and re-joined the team but none of the accounts work.

Hey everyone!
Could you try what I have said in another post in the meantime?

Tutorials are all well and good but you can’t make edits to them after students have forked the assignment because the edits don’t propagate to the student copies. The instructions do. Let’s say I want to add an example or there’s an unfortunate typo in my file - if I edit mine, the edits show for the students. But the tutorials folder gets copied to student projects, meaning you can’t modify it. I mean you can for future, but not for the current students.


I believe this issue is a duplicate of: Instruction tab does not pops up automatically, not found under Tools for certain students

Here is my most recent response on that one:

Hey all!

I checked internally and the engineering team is aware of and is tracking this internally. That said, we cannot say for certain when we’ll see an update here, though. Thanks for your patience.

Any updates on this, because it has happened to us too. They were working fine before the summer break. They look right on teacher account, but not on student account. Then started randomly working for some students.

1 Like

All we know for sure (as of two days ago) is that the engineering team is aware of the issue.

Strange theory but could it somehow be an ad-blocker causing the issue? Because the Instructions tab gets loaded after the entire page, is there a chance that some ad-blocking techniques are seeing this as a false positive? I hadn’t thought about that until just now.

I am also seeing this issue. Here’s a workaround that worked for me:
Within the repl, click on the “…” in the upper right corner. In the search bar, type “Instructions”, click on the Instructions option that appears.

More details:
MacOS Ventura version 13.2.1
Chrome Version 111.0.5563.64 (Official Build) (arm64)

Thanks - in my experiences with this issue (last school year), we could not find the instructions tab no matter what we tried. Including that method.

Thankfully I’ve not run into the issue yet with my current classes.

My students are having the same issue. I tried using the three dot menu on the right top corner and it works if the student types it with a lowercase “i” → shows up. It shows them the file instead of the preview version though. So I have to tell them to click on the ‘eye’ preview button on the tab so it can be displayed nice and neat.

Hey @RicardoSerrano3!

Can you please send me the link to the project that your students are having issues with? Also, are you and your students having the issue with the instructions tab, or just your students?

just some of my students. Here is the link

1 Like

Thanks! I wasn’t able to reproduce this when copying the environment of the Repl. Would you mind sending me the username of a student that is having the issue and the username of a student who isn’t seeing the issue so I can compare their settings and environments?

If you don’t feel comfortable posting the usernames here, feel free to message me by clicking my profile picture and clicking “Message”!

The student who has this issue: @adianginting891
The student who doesn’t have this issue: @12ta2nguyenhoan


Thanks for sharing the info. Please check your email for the news on the deprecation of Teams for Education. It mentions that Teams for Education will no longer receive bug fixes or updates.

I made tutorials for all my Teams for Edu lessons last year. This year some of the tutorial folders are missing from the duplicated teams… and the original one as well (I had archived it). Not sure what was going on there but think it might be a little buggy too.