Installing typing-extensions package doesn't work

Anyone know why this happens and how to the problem?
Repl Link: https://replit.com/@pilotpwixie/wBot
When I try to install, an error pops up stating:

--> poetry add 'interactions.py ==5.11.0'

  AttributeError

  'EmptyConstraint' object has no attribute 'min'

  at venv/lib/python3.8/site-packages/poetry/core/packages/utils/utils.py:252 in create_nested_marker
      248│             name = "python_full_version"
      249│ 
      250│         marker = '{} == "{}"'.format(name, constraint.text)
      251│     else:
    → 252│         if constraint.min is not None:
      253│             op = ">="
      254│             if not constraint.include_min:
      255│                 op = ">"
      256│ 
exit status 1

Does anyone know why this happens?

Hi @pilotpwixie , welcome to the forums!
Could you try entering poetry add interactions.py == 5.11.0 in the Shell instead (removing the '')?
Hope this helps!

2 Likes

same thing happens when I do that

~/wBot$ poetry add interactions.py == 5.11.0

  AttributeError

  'EmptyConstraint' object has no attribute 'min'

  at venv/lib/python3.8/site-packages/poetry/core/packages/utils/utils.py:252 in create_nested_marker
      248│             name = "python_full_version"
      249│ 
      250│         marker = '{} == "{}"'.format(name, constraint.text)
      251│     else:
    → 252│         if constraint.min is not None:
      253│             op = ">="
      254│             if not constraint.include_min:
      255│                 op = ">"
      256│

It happens when I install any package (not just interactions.py

Could you try just adding interactions.py without the version number?

If that fails, could you share your pyproject.toml file?

It shows this now:

AssertionError

  

  at venv/lib/python3.8/site-packages/poetry/core/packages/utils/utils.py:244 in create_nested_marker
      240│             name = "python_full_version"
      241│ 
      242│         marker = f'{name} == "{constraint.text}"'
      243│     else:
    → 244│         assert isinstance(constraint, VersionRange)
      245│         min_name = max_name = name
      246│ 
      247│         parts = []
      248│
[tool.poetry]
name = "discordbottemplate"
version = "0.1.0"
description = ""
authors = ["Pyx, wpyxpilot@proton.me"]
[tool.poetry.dependencies]
python = ">3.10,<3.8"
flask = "^1.1.2"
replit = ">2.0.0,<3.0.0"
python-dotenv = "^0.15.0"
termcolor = "^1.1.0"
"discord.py" = "==2.3.2"
[tool.poetry.dev-dependencies]
replit = ">2.0.0,<3.0.0"
[build-system]
requires = ["poetry>=0.12"]
build-backend = "poetry.masonry.api"

Interesting, that version listing seems slightly incorrect, try changing:

to:

"discord.py" = "2.3.2"
2 Likes