Input(prompt) does not take cursor at the end

**Question: **

Today is my second day on your website and whenever I use input(prompt) it does not take the cursor at the end so it does not give the user the input to type anything.

Sounds like you need to use the “with prybar” template. Either that or run your code file via the shell tab with ‘python’ (which defeats the purpose of the run button)

I really don’t get why they change the console. Almost nobody likes the new one. :man_shrugging:

Thank you for your quick reply.

Prybar is just for running code within the console (e.g. typing 2+2 would output 4), so it’s really dumb that you can’t even type in the Console without it. But, you know, it’s Replit.

@Peace777 If that solution worked for you then please mark his reply as Solution.

1 Like

Thank You! Today is my second day on this site and I am trying to familiarize myself with your platform. How do I change the template to Prybar? Are there any steps I can follow? I will need the steps from the template I currently have on the screenshot pasted in my earlier post. I appreciate your help.

You can’t change templates, you will have to create a new Repl and search for the correct template.

To enter input, make sure you click in the console (after the ‘what is your name?’) so that you are typing in the console. You should see a white rectangle appear, that is your cursor.

1 Like

Ok, thank You! I have worked with other IDE’s but not this one. Hopefully, I will have fewer questions after a few days. Thanks

1 Like

Well, as MrBrash said in another post:

That way you don’t have to migrate your whole Repl over to another template. Let me know if you don’t know how to change the .replit file


you can see from the screenshot: they’re using a legacy repl which already does use prybar by default, which is why it says Interpret and not Run.
Still, though, there’s benefits of moving to the new system: migrate your .replit and replit.nix config to match the latest prybar template, and remove the hidden venv folder.

But I can’t reproduce any issues with the cursor disappearing on day-1-printing-start or on a fork of that repl.

1 Like

Thank you! Actually, I bought a course on Udemy and their screenshots and current screens on your platform do not match. I am absolutely new to your platform. Not your fault. Maybe my fault that I got enrolled in a course that has not been updated recently in my opinion so that is the reason I am facing some issues. I have to make sure that I use the same template that the instructor is using so that I can follow her steps. I have to take a couple of steps to see the cursor but don’t worry. I appreciate all your answers. Thanks