In need of program help

**Question:**How do I test my program, I have no run errors. Also, how do Find and attach the link for my program once I have tested it? Thank you in advance.

Current behavior:

Desired behavior

Repl link:

code snippet

Hi @urajoo1 , welcome to the forums!
What language are you using?
To get the link of your repl, enter the repl, and copy the url from the address bar. We can then view the repl from the Cover Page.
Hope this helps!

Nate, I am having to make this replit in Python for a capstone to finish out a college course. I just needed to make sure it works before I send it in. And I also could not find the test feature. Thanks

Tests are included in each repl. Go to Tools > Tests to setup one.
Or, you can use the pytest module to test your code.
However, with no run errors, the tests should be correct.

@urajoo1 The program won’t show any output as the function isn’t called, so no output appears. After defining the function, you should call it so you can see the output.

Very cool, Thank you

Hi @urajoo1 !
Has my post above helped you to solve your problem? If so, could you mark it as a Solution? If not, what errors or problems do you encounter?

This is what I am getting when I run the program in the console. The second pic is what I have for options, I do not see the test button. The program is not published, but I need to turn it in so if you think it’s good I will go ahead and do it for my grade. Thanks for your help.

Hey @urajoo1, we only got the image of your sidebar, could you resend the other one?

This is the other one.

Could you check the replit.nix file of that Repl? It seems to be messed up, and there’s likely more than one issue in it.



Show hidden files

1 Like

This is what I got when I ran the replit.nix.

Try removing all the pkgs lines from that file except for the last one. (Also that doesn’t “run” that file, it just runs your main file)


I removed the other packages and left the last one. When I run the main file the nix error on the right is what I get. Any help would be appreciated, I am trying to turn this in today if I can know it’s correct. I am sending this into learning for the college credits of that helps any. Thanks in advance for your help.

Try removing that last package line then, it seems that it was invalid as well.

Removed last package this is what I got.

Looks like you removed the end of the nix file, try changing it (in it’s entirety) to:

{ pkgs } : {
  deps = [

Changed it in the nix, got this error. Not sure what’s going on.

Found the error:
You’re missed a “;” after the closing bracket. Needs to be:

{ pkgs }: {
	deps = [

Besides that, there’s no other errors with the nix. All that writing above is the traceback.

1 Like