I'm trying to Create a ReactBricks App, I'm facing the following errors

I’m trying to Create a ReactBricks App, I’m facing the following errors mentioned below.

~/Portfolio-Starter-by-Clever-Programmer$ npx create-reactbricks-app
Create ReactBricks App v1.2.9

? Do you already have a React Bricks account? (Y/n) y
? Please, enter your React Bricks account e-mail:
(CENSORED)
? Password: *********
? Choose your app or create a new one: portfolio-yt-app
? Project name (insert a valid package name): portfolio-yt-app
? Folder name: portfolio-yt-app
? The selected folder already exists: Replace folder content
? What would you like to create today? Website and Blog with
Tailwind (recommended to start)
? Select framework: Next.js with Pages Router
? Load some pages with default content (recommended)? (Y/n) Y
:heavy_check_mark: Downloading starter
:heavy_check_mark: Downloading React Bricks UI
:heavy_check_mark: Setting project configurations
:heavy_check_mark: Saving app credentials
:heavy_multiplication_x: Command failed with exit code 1: yarn install
error react-tag-autocomplete@7.2.0: The engine “node” is
incompatible with this module. Expected version “>= 16.12.0”. Got
“14.18.3”
error Found incompatible module.
yarn install v1.22.17
info No lockfile found.
[1/4] Resolving packages…
[2/4] Fetching packages…
info Visit yarn install | Yarn for
documentation about this command.
:black_medium_square: Setting up git repository
:black_medium_square: Creating pages with default content
Error: Command failed with exit code 1: yarn install
error react-tag-autocomplete@7.2.0: The engine “node” is
incompatible with this module. Expected version “>= 16.12.0”.
Got “14.18.3”
error Found incompatible module.
yarn install v1.22.17
info No lockfile found.
[1/4] Resolving packages…
[2/4] Fetching packages…