I'm getting a version `GLIBC_2.38' not found when trying to deploy

Question:

2024-02-07T01:43:38Z info: Deployment: a60c286e-1993-44c3-9223-9517e9746e21
2024-02-07T01:43:38Z info: Build: c7773d6f-bde4-4f93-8e2c-5615d9f04113
2024-02-07T01:43:38Z info: Connecting to builder
2024-02-07T01:43:41Z info: Builder connected
2024-02-07T01:43:42Z info: Installing packages
--> poetry lock --no-update

/nix/store/9vafkkic27k7m4934fpawl6yip3a6k4h-bash-5.2-p21/bin/bash: /nix/store/dg8mpqqykmw9c7l0bgzzb5znkymlbfjw-glibc-2.37-8/lib/libc.so.6: version `GLIBC_2.38' not found (required by /nix/store/9vafkkic27k7m4934fpawl6yip3a6k4h-bash-5.2-p21/bin/bash)

exit status 1

Repl link:

[tool.poetry]
name = "lstm-bot"
version = "0.1.0"
description = "A brief description of your project"
authors = ["Myself"]

[tool.poetry.dependencies]
python = ">=3.10.11,<3.12"
numpy = "1.23.5"
pandas = "2.0.3"
ta = "0.10.2"
torch = "1.13.1"
scikit-learn = "1.2.2"
lumibot = "3.0.6"
#alpaca-trade-api = "3.2.0"

[tool.poetry.dev-dependencies]
pytest = "6.2.4"

[tool.poetry.group.dev.dependencies]
ipykernel = "^6.29.0"

[build-system]
requires = ["poetry-core>=1.0.0"]
build-backend = "poetry.core.masonry.api"

5 posts were merged into an existing topic: GLIBC Python version incompatibility

This topic is a valid bug report but has already been reported. Please search before posting bug reports in the future.

The original bug report can be found here.