I need help with python bottle

I created a bottle project in Python!
Now it says that “Bottle” is not a module!

Traceback (most recent call last):
  File "main.py", line 3, in <module>
    import bottle
ModuleNotFoundError: No module named 'bottle'

And it worked before…
I think because of the update

Hi @BenjaminHehe

Can you post a link to your Repl please?

I also want to check that you have the bottle.py file in your Repl?

1 Like


I edited this to remove join link

Thanks @BenjaminHehe I’m in the Repl at the moment.

I’m going to try removing the bottle package (sorry , my misunderstanding I thought you had made the package) and restart the Repl. I’ll update this again when I’ve finished.

That’s weird. When you reinstall the bottle package it says it is successful but if you go to Shell very quickly after the success message appears it says that the package install failed.

I’ve now moved this topic to Bug Reports so hopefully it can be investigated. Sorry about the inconvenience!

1 Like

Okay… That is fine!
Thank you!

1 Like

Was bottle deleted?

I’ve never heard of bottle, but you should be able to install any Python package in any Python Repl. However, that does not mean that it will show up as a template (those are manually approved by mods/staff). Also I don’t think that it will find anything if you include the word “template” in your search. Those are all templates and I believe it searches for your entire phrase so unless there’s a template called “bottle template”, it will not show even if there’s a template called “bottle”.


I did use a template called “Bottle template”!
Also here is the bottle website: https://bottlepy.org/docs/dev/
We did try installing the bottle package but nothing worked!

Ah I see. The reason it did not appear in the templates list is because it is a community template. I forked your Repl and ran pip install bottle in Shell and it worked. Could you try the same?


It worked!
Thank you for your help!

1 Like

Just wanted to confirm that there was a Bottle Template and this was removed because it caused the above issue.

Glad you now have it working!


It didn’t get removed it was a community template, and I forgot…


Ah! So that’s why I couldn’t find it yesterday. The template has an issue though and shouldn’t be used. Thanks for confirming!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.