I need help please I downloaded the py-cord dependency and tried to upgrade pip to run it but now I have some issues with my base code to run my bot

Question:

Repl link/Link to where the bug appears:

Screenshots, links, or other helpful context:

It’s hard to say what happened when you changed your dependencies, but the error is pointing out that bot does not support async with.

If this is unexpected, compare the version of the bot library you’re using to the latest released version listed on pypi, and compare the documentation to see if something has changed in the library itself.

2 Likes