I have no .replit file and I can’t make one

It gives me error when I try to make one, I even tried using shell, I even tried going to GitHub. I have no .replit file.
Yes I had show hidden folders on.

I am using Java

The .replit File is a hidden file inside the Config Files of a Java Repl normally.
Make sure first that you show hidden files.

If yours is missing inside your Java Repl do the following:

  1. create a new Java Repl
  2. show hidden files
  3. open the .replit file from the new Repl
  4. copy all code from it inside Code Editor to Clipboard
  5. switch to your existing Repl
  6. add a new file with name .replit
  7. open it in Code Editor
  8. paste the text inside your clipboard inside

Like I said, it won’t let me create a new .replit file

1 Like

What happens if you create a new Java Repl?
Do you see a .replit file inside?

1 Like

Yes, it’s just the one project. Maybe I should just start anew and copy paste


I forked your Java Project and see the .replit file inside the config section (after clicking on Show Hidden Files).

But the Replit.nix file is inside the wrong location (not inside the Config Section).
It should be renamed to replit.nix

And the .replitfile is empty (no lines inside).

Starting a new Repl and copy paste your Java Files sounds like a good idea.

1 Like

Oh yeah I
After I made the previous post I went on a different device and tried making a .replit file and it worked, that’s why there was one and why it’s empty.

Still not sure why it wouldn’t let me do it before, or why it was missing, might file a bug report

Hey @Mochatitan!

Can you please send me the link to your Repl that you’re unable to create a .replit file for so I can take a look?

1 Like

Welcome to the c0okmkmunity!

1 Like